I'm running Ubuntu 16.04 LTS, and I found out that every time a process named "collector" ran, the amount of ram memory used increased a little bit, (100MB every minute or so). I always keep an eye on the ram reported by the System Monitor, and this time almost all my RAM was being used, but apparently no process or program running at the time, could evidently be blamed for the entire usage of it.

After boot up, it was very common for my laptop dv6-6167la HP, to show 1.1GB of ram used (that's a healthy sign for me). And you could leave the laptop there for an hour, without further activity, you could come back later, and you could see the same value with no increment at all. Now, with the problem, if you leave the laptop for 40 minutes or so, the RAM is almost all consumed (5GB used out of 6GB).

I found out that by killing the process or command named "collector", the RAM used stopped increasing. This is important. My solution for this problem is not a permanent one. Every time after boot up, I have to open up terminal, use the "top" command, check for the PID of the "collector" command or process, and kill it manually, and by doing this, the RAM used does not increase without reason.

I'm looking for a permanent solution. I don't know if I have a malware inside, or something like that. If I don't kill the process, the computer gets very hot, the ram is all eaten up, and everything slows down. My computer is up to date, and the problem persists everytime I turn it back on, or even when I restart it.

I did remove a "collector" app from ubuntu (sudo apt-get remove collector), but the process is always activated by root after boot up, even though this app has been removed.

I would appreciate your thoughts on this issue.


enter image description here

PS. Based on the first reply, I've run the command "locate collector", and this is what came up. It seems suspicious to me the line which says:


, I don't know what this is. I ran the dpkg -S without getting valuable info. It only showed:

webapp-container: /usr/share/webbrowser-app/webcontainer/webapp-specific-page-metadata-collector.js

enter image description here

enter image description here

  • Do you have visual studio on your system? – WinEunuuchs2Unix May 26 '18 at 2:10
  • You don't need to use a separate terminal to kill things in top. Just press K and either Enter for the process at the top or enter the PID; then, press Enter for SIGTERM or enter 9 for SIGKILL. You can also get full command lines, which sometimes include full paths of the executables, by pressing C. For more top tips, press H once and twice for the two help pages. – Chai T. Rex May 26 '18 at 6:53
  • I don't have Visual Studio inside Ubuntu. Only in Windows 7. My laptop is a dual boot one. – Berham Horadrim May 28 '18 at 4:27
  • Thanks for the tip. I used the two window approach, so I could see the collector command disappear effectively after ordering to kill it. – Berham Horadrim May 28 '18 at 4:31

kill -9 'pgrep -f collector' can be set to run with cron every so often, which will kill the collector PID.

As to what collector is, I was unable to find collector in the Ubuntu distro. There are several found with a search on COLLECTOR IN LINUX and they all 'phone home' with some kinda data set.

| improve this answer | |

locate collector led me to:

$ locate connector

And then dpkg -S told me which package it was in:

$ dpkg -S /usr/lib/ruby/vendor_ruby/test/unit/collector.rb
ruby-test-unit: /usr/lib/ruby/vendor_ruby/test/unit/collector.rb
| improve this answer | |
  • I used your command "locate", and I've posted the info from my terminal. – Berham Horadrim May 28 '18 at 4:32
  • Don't post images of text! Copy and paste the text, then use the '{}' formatting tool. You've found that the package containing collector is in the webapp-container package. Do a dpkg -L wepapp-container to see other files in the package, some of which may be documentation. – waltinator May 28 '18 at 13:28

Problem solved. There are two packages that need to be removed:

#sudo apt-get remove bootchart
#sudo apt-get remove pybootchartgui

Now my computer starts with 0.97GB occupied of RAM, instead of 1.1GB, and it does not keep increasing as before without reason. Everything functions properly.

This is a permanent solution.

Moreover, the executable "collector" had no documentation at all inside its folder. No help function either.


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.