I am trying to install MYCROFT on Ubuntu 18.04 following this: LINK

cd ~/
git clone https://github.com/MycroftAI/mycroft-core.git
cd mycroft-core
bash dev_setup.sh

I am getting this error:

sudo: easy_install: command not found

This error is because the script dev_setup.sh line 168 is trying to execute:

easy_install pip==9.0.1 # force version of pip

I have installed:

sudo apt-get install python-setuptools
sudo apt-get install python-pip python-dev build-essential

However the


command is still not recognised. Any ideas?


By commenting out that line in the script allows the script to run. However there is a module error, voice recognition module missing, when doing an audio test.

  • I can't reproduce your errors on clean installation of Ubuntu 18.04 LTS (both with --depth=1 and without). Do you have python-related PPAs?
    – N0rbert
    Commented May 25, 2018 at 21:06
  • 2
    easy_install is part of python-setuptools. Please add the output of apt policy python-setuptools to your question. Commented May 25, 2018 at 21:20

6 Answers 6


On Ubuntu 18.04 I was able to pip install python-setuptools and run easy_install by full-path'ing it:

python /usr/lib/python2.7/dist-packages/easy_install.py pip

I prefer this over installing the python-pip system package because pip is moving faster than the distros update it, so I install it from PyPI.


  • Thank you for this answer! I was frustrating myself because I was using find / -xdev -name easy_install so I wasn't finding easy_install.py (because of the .py extension). You probably just saved me from trying some ridiculously desperate solution.
    – chris
    Commented Nov 27, 2018 at 20:55
  • You're welcome! A trick I keep in my back pocket when find doesn't return anything is falling back to a more fuzzy search like: find / -iname '*easy_install*'. This will return files containing case-insensitive easy_install anywhere in the name; even if it's prefixed or suffixed with something.
    – berto
    Commented Nov 29, 2018 at 15:42
  • 2
    An easier version than this is to run python -m easy_install pip
    – taxilian
    Commented Feb 3, 2020 at 18:52

According to the changelog easy_install was removed from the python-setuptools package.

I've got no good news for you; I've not found a solution short of updating the legacy scripts to use pip (and hoping the version pip installs works).

In your case its pip you're trying to get from easy_install, so you can probably omit the line since the version of pip in bionic is 9.0.1-2. A better change to the script might check that pip --version is less than 9.0.1 before trying to install that alternate version via easy_install.

  • lol to anyone struggling to load a 3rd party library that provides .egg files! And provides .whl files that are "incompatible with your system"! Commented Sep 25, 2023 at 4:58

I got this from this link: I am not able to install easy_install in my ubuntu.

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install python-setuptools

If that doesn't work, try this:

sudo apt-get install python-pip

sudo pip install <pypi-package>

Credits to: https://askubuntu.com/users/157039/m-tarun and https://askubuntu.com/users/20837/timo


On Ubuntu 18.04, I got the same error several times, I searched on many links but didn't get a useful solution.

For this, the version of the pip should be less than or the same as 9.0.1.

First of all, install the pip for python version 3 from-

sudo apt install python3-pip

and check pip version-

pip --version

after that, we have to install build-essential for python-dev

sudo apt-get install build-essential python-dev

and python setup-tools

sudo apt-get install python-setuptools

And finally, we are able to install pymongo by following command-

python -m pip install pymongo

It worked for me, may it will work for you too.

  • This worked for me, but I used sudo apt install python-pip instead of installing python 3
    – Lamya
    Commented Apr 25, 2020 at 12:25

easy_install is not a part of python setup-tools so instead you can go for pip3 for installing python modules if pip is not found the following should solve your issue.

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install python3-pip

This worked on my side, all others mentioned here failed:

sudo apt-get update
sudo apt-get install pip
sudo apt-get install python3-setuptools
sudo apt-get install python3-pip python3-dev build-essential
  • 1
    This answer nearly replicates the approach mentioned in the question. So no real improvement.
    – zx485
    Commented Feb 5 at 2:13
  • Cannot you see the difference? What do you mean by "nearly" replicates? Elaborate Commented Feb 5 at 15:12
  • In the above answer given 5 years ago the same packages were suggested to install. Hence no improvement. Most of these packages were even mentioned in the question as well.
    – zx485
    Commented Feb 5 at 17:20
  • You still cannot see the difference, I have no energy wasting explain anything; Just Chill Commented Feb 6 at 15:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .