5

Recently I bought a new laptop that came with Windows 10 installed but not activated. I use both Windows 10 and Ubuntu 18.04, so I tried making a dual boot with a USB flash drive. It was recognized by the BIOS, I tried Try Ubuntu without installing and Install Ubuntu. With both options the PC freezes, and I need to press the power button. It's shown very fast some errors that are listed below:

[ 0.064522] ACPI Error: Method parse/execution failed \_SB.PCID.RPOB.PXSX, AE_NOT_FOUND (20170831/parse-550)

[ 0.066316] ACPI Error: [_SB.PCID.RPOB.PXSX], Namespace lookup failure, AE_NOT_FOUND (20170831/download2-191)

[ 0.066325] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)

[ 0.246232] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

[ 0.246248] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

[ 0.246260] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

[ 0.246272] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

[ 0.246285] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

[ 0.246297] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

[ 0.246310] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

[ 0.246322] ACPI Exception: AE_NOT_FOUND. Evaluating _PRS (20170831/pci_link-176)

I'm using NVIDIA GTX 1050 Ti graphics card and Intel i7-8750H processor. I talked to the customer support and they just said that my laptop might not be compatible with Ubuntu. I also tried Ubuntu 16.04, but there were no changes.

EDIT: Thanks a lot for all the answers, but unfortunatelly I returned the PC to the store, neither the technical support found a solution for the problem, they just said: "Our PCs are just able to work with Windows, anyother OS might work but without our warranty".

3

I have been having a similar problem with my Dell XPS 15. I posted a question very similar to yours and someone helped me find a solution to the issue. It is possible that the errors and freeze are due to the Nvidia graphics card. I was able to get passed this error using the 'nomodeset' trick. See the comments in my post located here: Running Ubuntu via live USB error on Dell XPS 15 9560

1

Some computer don't work well with Ubuntu because of "ACPI issues ... like My Cutting Edge Omen X. I pulled my hair out for a couple of days, and now on my third day I may have it solved or at least much better.

• Symptoms

not loading / booting

hundreds of "acpi INT3400:00: Unsupported event [0x86t" errors at booting up and shutting Down,

and sometime endless errors crippling startup and shutdown

‣ also Nvidia was not playing nice, and my HDMI wasn't working right

‣ All seemingly related WOW

• Make NO ACPI IN Ubuntu,

∘ Edit the grub file with this command in terminal:

sudo gedit /etc/default/grub

∘ Make the similar in the Grub file line look like this

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

∘ Update Grub with this command:

sudo update-grub

∘ Reboot - &&&&& Good Luck

1
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=strict"

Is way better, and changing timeout from 90 seconds to 3 seconds stopped the still less frequent recurring errors from making booting or shutting down Unbearably Long or even forever.

Trying to help, Mark p.s. ok forgot how and googled it for you sudo gedit /etc/systemd/system.conf

and change the defaul unbearable 90s to 3 (in my case) ∘ DefaultTimeoutStartSec=3s ∘ DefaultTimeoutStopSec=3s

Trying to help MORE Mark

1

The solution suggested in the below link to use nomodeset in /etc/default/grub works fine for Dell XPS 15. But it won't load your acpi drivers due to which I am not able to use the brightness controller.

You can also try to boot in with the recovery mode which by default doesn't load your graphics drivers allowing you to boot into your system.

http://www.dell.com/support/article/uk/en/ukbsdt1/sln306327/manual-nomodeset-kernal-boot-line-option-for-linux-booting?lang=en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.