I have installed a fresh copy of Ubuntu 18.04 on my PC with an AMD HD7900 Graphics Card. I believe the code name is 'Tahiti'

First thing I did was install the Oibaf PPA


Then I did a sudo apt-get update && sudo apt-get upgrade && sudo apt install mesa-vulkan-drivers

When I type vulkaninfo, I get the following message.


Vulkan Instance Version: 1.1.70

/build/vulkan-Kbdbga/vulkan-1.1.70+dfsg1/demos/vulkaninfo.c:2700: failed with VK_ERROR_INITIALIZATION_FAILED

I find the Vulkan guidance very confusing so would appreciate any help. I'm hoping to play the new Tomb Raider game.



I used the following instructions which got the game working just fine on a clean install of Ubuntu 18.04...you still get the "CPU Governor" message but it can be set to "ignore".
Click through the warning messages, and go to the "Advanced tab" of FERAL games menu (not the in game menu).
After following the instructions below you'll see the Driver selected is the Vulkan TONGA driver.
Start the game and do the Benchmark first....It takes a while for the game to load but it does, and I get an average of 50fps on the benchmark.

Here is what I did pressing enter after each line:

  1. $ sudo add-apt-repository ppa:oibaf/graphics-drivers
  2. $ sudo apt update
  3. $ sudo apt upgrade
  4. $ sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils

I just resolved an issue related to this - the above was working fine for me on Ubuntu 18.10 without the PPA version. I had to reinstall Ubuntu (for a different issue), then it wasn't working. The solution depends on GRUB loading correctly. In my install, my GRUB install was bad so I had to delete GRUB and start again. This can be done from a live USB. I had a separate install of GRUB on another HDD that I upgraded from and sometimes my computer would boot from that and ignore the lines added to /etc/default/grub. It's weird. But reinstalling GRUB to the correct SSD made sure the correct GRUB config was used and Vulkan worked fine on my Radeon HD 7950 for reference.

P.S. make sure to use an editor to edit this line so it reads as follows in /etc/default/grub by typing into a terminal (Ctrl+Alt+T)

sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1"

Ctrl+O to write changes and Ctrl+X to exit. I got the line above from several other posts online. Then type

sudo update-initramfs -u

sudo update-grub

sudo reboot

enjoy! I did not have to blacklist the radeon driver - but it might be worth a try if this doesn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.