8

I created a Live USB with Ubunbtu 18.04 on it so I can look into dual booting on a Windows 10 PC.

When I boot Ubuntu from USB, I can't get my wireless keyboards to work. They both work on Windows, so there is no battery issue. They both use a wireless USB dongle. The wireless mouse with one of them works fine.

I used a wired keyboard to install xserver-xorg-input-all using sudo apt-get install xserver-xorg-input-all, but the wireless keyboards still won't work

Is there anything else anyone can suggest that I try ?

Edit:

Output from lsusb is as follows -

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0781:556b SanDisk Corp. 
Bus 001 Device 009: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 007: ID 17ef:60a9 Lenovo 
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 006: ID 0bda:0821 Realtek Semiconductor Corp. 
Bus 001 Device 008: ID 046e:550f Behavior Tech. Computer Corp. 
Bus 001 Device 004: ID 046e:5411 Behavior Tech. Computer Corp. 
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The SanDisk device is the Live Usb and Lenovo is the keyboard/mouse. The keyboard/mouse are as supplied with the PC and are Lenovo. My alternative set with the same symptoms is by Microsoft.

6
  • 2
    What keyboard model(s) are we talking about? If they're connected through a wireless USB dongle can you please connect it/them, run lsusb and add the output to your question? If it's via Bluetooth can you please add the output of rfkill list? THanks. May 29, 2018 at 18:11
  • 1
    If it's USB it really should work out of the box, can you add the VID/PID of the keyboard
    – jrtapsell
    May 29, 2018 at 18:54
  • @jrtapsell - Can you tell me what you mean by VID/PID of the keyboard ? May 29, 2018 at 23:11
  • @DavidFoerster - One of the keyboard/mouse combos is Microsoft and the other is Lenovo. They both have the same sympton. I'll get the 'lsusb' output and attach to the question shortly. May 29, 2018 at 23:12
  • Vendor ID, Product ID, lsusb should give you them
    – jrtapsell
    May 30, 2018 at 7:13

2 Answers 2

3
+50

Update January 2, 2022

This bug has been fixed according to the bug report: Lenovo Essential Wireless Keyboard doesn't works (Primax Electronics manufacturer) #36 which states:

Julian Alarcon (julian-alarcon) wrote on 2019-09-19: #36

This is finally fixed! I test it in Ubuntu 18.04 kernel: 4.15.0-64, Ubuntu 18.04.3 kernel: 5.0.0-29.

The keyboard and mouse seems to work fine with no issues! I had to disable a workaround used to make it work! https://github.com/y-trudeau/linux_lenovo_ultraslim_plus

Original post

The original post is shown below for historical purposes.

Extensive history to this problem

You are not alone. Someone in Ubuntu forums has reported:

Re: Lenovo Essential Wireless Keyboard and Mouse Combo doesn't work

I just reported this bug: Lenovo Essential Wireless Keyboard doesn't works (Primax Electronics manufacturer)

The bug is still present in the latest Ubuntu version (18.04 bionic beaver) with stable kernel.

It's also reported by people from Linux Mint, Fedora and others.

Possible workarounds

Although the bug has been confirmed by the Ubuntu Team, no one has been assigned to fixing it yet. In the meantime there are two workarounds:

1
  • Although his doesn't solve my problem as it isn't solvable yet it does give me some options to work round the issue. I asked for suggestions for what else to try and this certainly provides some. Thanks. Jun 4, 2018 at 9:50
1

If you tried the Lenovo fix from WinEunuuchs2Unix's answer and it did not work, you might want to try this modified fix that I made for another Primax (HP brand) wireless keyboard + mouse combo with similar problems:

https://github.com/JohnJohanssonChalmers/hp_wireless_keyboard

I have seen several reports of these types of problems with Primax keyboards that could not be solved with the Lenovo fix. I suspect that my modified fix might also wok for some non-HP keyboards.

2
  • Thanks. I'll take a look at this tomorrow when I'm at home. Feb 21, 2019 at 11:11
  • @jkej I've updated my answer and the bug has been fixed. Thanks for linking another possible solution though. Jan 2, 2022 at 22:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .