1

I keep getting this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  geoip-database-extra gir1.2-ayatanaappindicator3-0.1 gir1.2-gexiv2-0.10
  libayatana-appindicator3-1 libayatana-indicator3-7 libjs-openlayers libnl-route-3-200
  libqt5multimedia5 libsmi2ldbl libwireshark-data libwireshark10 libwiretap7 libwscodecs1
  libwsutil8 python-bs4 python-certifi python-configobj python-html5lib python-httplib2
  python-lxml python-olefile python-openssl python-pil python-pycurl python-requests
  python-urllib3 python-webencodings wireshark wireshark-common wireshark-qt
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 34 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up install-info (6.5.0.dfsg.1-2) ...
/usr/sbin/update-info-dir: 4: /etc/environment: Syntax error: Unterminated quoted string
dpkg: error processing package install-info (--configure):
 installed install-info package post-installation script subprocess returned error exit status 2
Errors were encountered while processing:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Output of cat/etc/environment:

     icebunny08@D3CRYPT3D:~$ cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/java/jre1.8.0_171/bin"
JAVA_HOME="/usr/java/jre1.8.0_171
  • 1
    What is the contents of /etc/environment ? Add output of cat /etc/environment command to the question. – N0rbert May 24 '18 at 20:06
3

You should edit your /etc/environment with text editor and add last quote (") to it.
For example with Nano:

sudo nano /etc/environment

change

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/java/jre1.8.0_171/bin"
JAVA_HOME="/usr/java/jre1.8.0_171

to

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/java/jre1.8.0_171/bin"
JAVA_HOME="/usr/java/jre1.8.0_171"

Press Ctrl+O to save, then Ctrl+X to quit.

  • I did the thing you said, and this is the output when I tried sudo apt-get dist-upgrade: Do you want to continue? [Y/n] y Setting up install-info (6.5.0.dfsg.1-2) ... W: APT had planned for dpkg to do more than it reported back (0 vs 4). Affected packages: install-info:amd64 – icebunny08 May 24 '18 at 20:53
  • 1
    Then run sudo apt-get install -f followed by sudo dpkg --configure -a. – N0rbert May 24 '18 at 20:59
  • I now get N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. – icebunny08 May 24 '18 at 21:42
  • Try to refresh package lists with sudo apt-get update, and upgrade packages with sudo apt-get dist-upgrade then. – N0rbert May 25 '18 at 9:09
  • Tried that, it still didn't work. – icebunny08 May 25 '18 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.