4

When I tried to start my computer, it boots in emergency mode and shows some problem. I don't know about these problem. if I run 'exit' command that again brings back the emergency mode. This is shown by system in first

After running 'exit' command

0

I had the same problem last night and I fixed it using the following steps:

Before starting it would be safe to backup all your data, though I didn't and came out of the problem without losing anything.

  1. First you must boot into your system using a live cd/usb and make sure you have all other devices unmounted from the system.

  2. Run this sudo e2fsck -C0 -p -f -v /dev/<partition_id>

  3. Repeat step 2. for each and every partition you have until you find the corrupted one.

  4. Upon finding the problem, it will show you something like this:

    Inodes that were part of a corrupted orphan linked list found.

    Home: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. (i.e., without -a or -p options)

  5. Then run sudo e2fsck -f -y -v /dev/<corrupted_partition_id>

  6. Press 'y' on every prompt to fix them.

  7. Reboot after completion of the full recovery process.

For a detailed information you may look into this link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.