2

I am looking for a solution or some guidance on where to file a bug.

On my 18.04 desktop installs (Gnome shell and Ubuntu Mate) when mounting network shares (SMB and NFS) they no longer appear under Devices in file manager (Nautilus or Caja), the mounts do succeed and are accessible at their mount points.

In 16.04 and 17.10 these mounts appeared under Devices ( Screenshot of mounted network shares on Ubuntu Mate 17.10)

I am using the following code to mount NFS shares

sudo mount.nfs 192.168.2.123:/mnt/freenas-data1/photobackup /media/philroche/photobackup

and for SMB shares

sudo mount.cifs //192.168.2.123/photobackup /media/philroche/photobackup

Is anyone else experiencing this and where should I file a bug, or perhaps it is an intentional change? I did ask this on IRC in #ubuntu but no reply.

A similar question was posted @ Nautilus not showing mounted drives in side bar

  • This problem is especially annoying when you want to open/save files in a GUI program without extra hoops to jump through. One quick workaround I found is bookmarking the directory (click into target dir, hit CTRL-D). – Hemm May 27 '18 at 13:59
1

I can only talk about a cifs mount.

I never noticed that before but it's probably because of how I mount these shares which you may consider as a work around for your situation.

I have a guest share that I want to mount. If I try to mount it your way it does exactly what you said:

sudo mount.cifs //server/share /home/morbius/Public -o guest

But if I mount it in fstab as a "mount as required" entry it does list it on the side panel of Nautilus. My entry in fstab would look like this:

//server/share /home/morbius/Public cifs guest,user,noauto 0 0

As soon as I save fstab a "Public" folder appears on the side panel of Nautilus. If I click on it ( as an ordinary user because of the "user" option ) the share is mounted . This will work if the mount point is in my home directory or under /media. It will not work if the mount point is anywhere else. Note: these shares will not automount (noauto). They will only mount when I click on the icon on the side panel. They can also be unmounted from that same icon.

I suspect what is happening here is that because of the mount point location and the fact that it is in fstab it induces a udisks response that forces the icon to appear on the side panel.

Also, for me these are known shares on known hosts so if you use mount.cifs manually to mount random shares on random hosts this workaround will not help much.

  • Thank you for your comment. Your workaround, while good, doesn't suit my use case and doesn't address the bug/regression. Your comment did prompt me to file a bug against udisks2 though bugs.launchpad.net/ubuntu/+source/udisks2/+bug/1773334. I'll leave this question open until I get a reply from there. – philroche May 25 '18 at 9:04
  • I suspect the true bug report is here including the gnome bug reports it references: bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1758398 You may be right that it is a udisks issue but you will notice that this problem does not happen with a gvfs ( gio ) mount: gio mount smb://192.168.2.123/photobackup – Morbius1 May 25 '18 at 10:30
  • Excellent, thank you. As such it does look intentional. – philroche May 25 '18 at 11:23
0

This has now been resolved as part of glib upstream updates.

https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/1773334 and https://gitlab.gnome.org/GNOME/glib/issues/1424. Specifically merge request https://gitlab.gnome.org/GNOME/glib/merge_requests/125

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.