9

I have a computer on Ubuntu 18.04 (actually upgraded from Ubuntu Gnome 16.04). I need to set up screen sharing but the option isn't there.

In settings > sharing, the master sharing switch is on and I see computer name, but underneath that only Remote login and File sharing - no option for screen sharing as the docs suggest it should be.

As per the title, vino is installed - maybe there's another package I need that somehow didn't transition between the two versions?

3

This question is old, but here's an answer:

Log out, and then start the login (select your user name) but before you enter your password, click the gear-icon...then select the "Ubuntu with Xorg" and NOT the "Ubuntu" option.

Log in, and go back to Sharing...you should see "Screen Sharing" there now.

  • 3
    I only see Ubuntu with wayland.. – Erik Oct 13 '18 at 18:12
  • 1
    Doesn't work anymore, only "Ubuntu with wayland" available, and that does not cure the problem – Johannes Jander Jan 6 at 23:24
  • In 19.04 after clicking the gear icon pick the "Ubuntu" option. You can then enable sharing, including "Screen Sharing" via Settings (gnome-control-center sharing). – Adam Monsen May 25 at 13:09
0
  1. sudo apt-get install dconf-tools
  2. dconf write /org/gnome/desktop/remote-access/require-encryption false
  3. /usr/lib/vino/vino-server --sm-disable start
  4. see "settings --> sharing" again
  • Why is that dconf command necessary? – Adam Monsen May 25 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.