1

for some need i have to install php5.3 on my ubuntu-16.04.php 5.3 i have installed from ppp:ondraj/php5.i have installed apache 2.2 .but while running apt-get install libapache2-mod-php5 it is showing

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ca-certificates : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 fontconfig : PreDepends: dpkg (>= 1.16.1) Depends: fontconfig-config but it is not going to be installed irqbalance : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 libapache2-mod-php5 : Depends: apache2-mpm-prefork (> 2.0.52) but it is not going to be installed or apache2-mpm-itk but it is not going to be installed Depends: apache2.2-common but it is not going to be installed Depends: php5-common (= 5.3.10-1ubuntu3.26) but it is not going to be installed Depends: ucf but it is not going to be installed Recommends: php5-cli but it is not going to be installed libblkid1 : Depends: libuuid1 (>= 2.16) but it is not going to be installed libfontconfig1 : Depends: fontconfig-config (= 2.11.94-0ubuntu1.1) but it is not going to be installed libqt5svg5 : PreDepends: dpkg (>= 1.15.6~) Depends: libqt5widgets5 (>= 5.3.0) but it is not going to be installed libsasl2-modules:i386 : Depends: libssl1.0.0:i386 (>= 1.0.0) but it is not going to be installed libsm6 : Depends: libuuid1 (>= 2.16) but it is not going to be installed libsm6:i386 : Depends: libuuid1:i386 (>= 2.16) but it is not going to be installed libssl1.0.0 : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 libssl1.1 : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 linux-sound-base : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 locales : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 memtest86+ : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 monodoc-http : Depends: mono-xsp4 but it is not going to be installed or mono-apache-server4 but it is not going to be installed or mono-fastcgi-server4 but it is not going to be installed tzdata : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 wamerican : Depends: debconf (>= 0.5) but it is not going to be installed or debconf-2.0 E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

tried ppa-purge ppa:ondraj/php5 but the problem is same.

try to install from .deb source.here is the out put

Selecting previously unselected package libapache2-mod-php5. (Reading database ... 301538 files and directories currently installed.) Preparing to unpack .../libapache2-mod-php5_5.5.9+dfsg-1ubuntu4.25_amd64.deb ... Unpacking libapache2-mod-php5 (5.5.9+dfsg-1ubuntu4.25) ... dpkg: dependency problems prevent configuration of libapache2-mod-php5: libapache2-mod-php5 depends on apache2-api-20120211; however: Package apache2-api-20120211 is not installed. libapache2-mod-php5 depends on apache2 (>= 2.4); however: Version of apache2 on system is 2.2.22-1ubuntu1.11. Version of apache2 on system, provided by apache2-mpm-prefork:amd64, is . libapache2-mod-php5 depends on php5-common (= 5.5.9+dfsg-1ubuntu4.25); however: Version of php5-common on system is 5.3.10-1ubuntu3.26. dpkg (1.18.4ubuntu1.4) breaks libapache2-mod-php5 (<< 5.6.4+dfsg-3~) and is installed. Version of libapache2-mod-php5 to be configured is 5.5.9+dfsg-1ubuntu4.25. dpkg: error processing package libapache2-mod-php5 (--install): dependency problems - leaving unconfigured Errors were encountered while processing: libapache2-mod-php5

any way i can solve the problem.it really needed i use php 5.3.thaks for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.