0

This question already has an answer here:

Why does the Ubuntu installer touch my internal HDD when I don't use any of its partitions and when I tell the installer to install GRUB on the external HDD?

I have tried this approach over the years, and this always happens. The latest attempt is with Ubuntu 18.04. I know this sounds like a million-time-asked dup, but I am stuck. The fact that people suggest the VirtualBox work around, or they suggest to disable the internal HDD (which I can't short of unplugging it) indicates to me that this is surprisingly hard to fix.

I have a Thinkpad laptop. BIOS settings allow legacy boot devices. The internal HDD is dual boot Windows and Mint, and it is an UEFI boot method.

I want to install ubuntu on an external SSD drive and have this drive one of the boot options from BIOS. External HDD is a MBR partition style, so traditional boot method is required. The BIOS is set to be ok with this.

If I install onto the external drive via VirtualBox, it works. This means that what I want to do is possible. My internal HDD is completely isolated when I do this.

However, if I do the installation a more traditional way, it always screws up my internal HDD booting. That is, I have use a usb stick to make a live installer and boot from it, the normal way to install Ubuntu, things go wrong.

During the installation process, I can choose where to install grub. I choose the external drive. I would expect this not to touch the internal drive. But after installation, I can no longer boot from the internal drive. grub seems to be missing. I can boot from the external drive.

(I fix it by connecting the external drive and booting into the HDD installation, and using boot repair.)

Why is my internal HDD being changed by the install process when I have followed all advice to leave it untouched?

marked as duplicate by Tim Richardson, karel, Thomas, Eric Carvalho, Kevin Bowen Jul 21 '18 at 21:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Probably it's because your primary system is using UEFI? I tried MBR/MBR setup and I can boot to internal/external as my wish. – Aryo Adhi May 23 '18 at 20:07
  • If you have UEFI, Ubuntu only installs to the first ESP - efi system partition usually sda. If installing in BIOS boot mode, then your selection of external drive for grub would work. But if BIOS install to external you may have to turn off UEFI boot to boot in BIOS/CSM/Legacy mode. Need to see details. Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info I always suggest using gpt for any Ubuntu only drive, so then you can boot in either BIOS or UEFI, if you have correct supporting partitions. – oldfred May 23 '18 at 20:30
  • Thanks ... I can make it boot off the external drive. The problem is that I can no longer boot off the internal drive. Yet I did not install to the internal drive and I told the installer to put grub on the external drive. Somehow, despite my setting, the installer is affecting the internal drive, and when I say affecting, it is destroying grub on it. – Tim Richardson May 24 '18 at 3:53
0

The solution is to use gparted to turn-off the boot flags on the internal drive's EFI partition before doing the installation. This requires installing gparted from the Ubuntu live disk, it's not part of the software on the image.

The problem is a bug the Ubuntu installer: it always uses the first EFI partition it finds, regardless of the choice you make. But by hiding that EFI partition, you can work around it. You need to create an EFI partition on your target device before doing the install. Set the flags on it.

More detailed explation of the work-around is here: https://askubuntu.com/a/1056079/152287

Bug report is here: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1396379

Not the answer you're looking for? Browse other questions tagged or ask your own question.