0

LibreOffice does not do two-sided printing on HP OfficeJet Pro 7740. I loader HPLIP for Linux version 3.16.10 (the last version which fully supports the 7740). The printer is connected by USB cable. On both Ubuntu MATE 17.10 and 18.04, LibreOffice printer setting show 2-sided long-edge duplex printing. The HP Device Manager shows 2-sided long-edge duplex printing. The printer properties at print time show 2-sided long-edge duplex printing. Then LibreOffice prints only 1 side.

By accident, I discovered that Chrome does print 2-sided. This seems to indicate that the problem is in LibreOffice.

1
  • I think this problem is more to LibreOffice related than Ubuntu related.
    – Aryo Adhi
    May 23, 2018 at 19:07

2 Answers 2

1

In Libre Office Click on File > Printer Settings

In the pop up dialogue box click Properties

On the Paper tab check that "Duplex" is set to Long Edge (Standard)

On the Device tab under options in the left column, check that "Duplexer Installed" = Installed

On the **Device tab check that "Printer Language Type" = PostScript (Level from driver)

Click "Ok" and the document you are working in should print double sided.

3
  • Dear Burried Alive, I thank you for your answer. I already did all that. It just does not work and I have been unable to contact anyone from the LibreOffice project. Oct 29, 2018 at 14:37
  • Wonderful advice. It just does not work. HP OfficeJet Pro 7740 connected with a USB cable. Ubuntu MATE 18.04 18.10 19.04 and 19.10. Program allows setting duplex printing but still does only one-side printing. This bug is more than 5 years old and counting. No one yet assigned to actually fix it. Jan 1, 2020 at 2:22
  • Switching the Printer Language Type from PDF to PostScript solved it for me, thanks! Dec 19, 2020 at 16:27
1

Also check:

Menu -> Administration -> Printer -> *Right Click on you Printer* - >"Installable Options" 

and fill-in the CheckBox for "Duplexer Installed".
This now works for my HP Officejet 8610!

1
  • I don't understand why was my "Answer" Edited? Did I use the textual wrong format?
    – Authordave
    May 22, 2019 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.