47

Some time ago, Ubuntu introduced a Security "feature", that would only allow trusted .desktop apps to be run, on other apps it would pop up a message.

Nothing new so far, However, said Message used to have a button to make the app "trusted", but that button doesn't exist anymore:

alt text

What's the point of this dialog?

  • Additional hint: After finding that and trying it with only partial success, I found this, which explains it how to make a correct desktop file and where to place it: askubuntu.com/questions/13758/… – Henning Feb 22 '14 at 2:19
50

This dialog exists for your own safety, annoying as it is. To remove it, right click the launcher, click properties, and then go to the permissions tab and choose execute for the users you want to allow.

This will allow you to use the launcher from now on.

To do this for a large amount of launchers in the same directory, open a terminal (in the same directory) and run:

chmod +x *.desktop
  • 1
    Would someone mind explaining how it is that this dialog exists for users' own safety? What kind of protection is it providing? – J. Taylor Oct 5 '15 at 7:13
  • 5
    @J.Taylor Suppose you download a .desktop file in your web browser, or receive one in a file transfer while instant messaging. Typically it would not have executable permissions (if it did, this would be considered a bug in the browser or IM client). This gives you the chance to decide if you want to run it. In contrast, most kinds of files don't run code, that can do anything as the user that runs them when opened. To open a word processing document or watch a video there's no extra step; to run a downloaded program or .desktop file, there is, to ensure this is really what you want. – Eliah Kagan Jul 24 '17 at 3:51
  • Also be sure that exec file that *.desktop is pointing also must be executable – Andrew Luca Oct 30 '18 at 11:51
20

Right click the launcher and press "Properties", in the "Permissions" tab you will find a checkbox marked Execute, make sure that it is checked and Ubuntu will stop bugging you.

alt text

  • This option is greyed out in my installation. I am using Ubuntu Studio 18.04 – R B Aug 18 '18 at 10:19
  • @RB Probably you don't have write access to the directory the file is in, or the file is on a filesystem that doesn't support execute permissions. If you need more details, please ask a new question. – wjandrea Sep 29 '18 at 0:24
0

This may also appear if any of the paths in your .desktop files are malformed or do not refer to existing files or directories. Check that all the path names in your .desktop file exist, and this will often fix the problem.

protected by souravc Jun 13 '17 at 6:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?