1

I recently updated to 18.04 . My laptop has an Optimus configuration so both Nvidia and Intel cards. I could not get past the login screen of Gnome using Xorg. The mouse and screen would freeze. I found that by deleting xorg.conf that I could then login. If I tried generating an xorg.conf file with nvidia-xconfig . This xorg.conf file would again freeze my login attempts soI would again delete the xorg.conf file. My problem is that nvidia-settings and Gnome settings now do not see a second attached monitor. Xorg is using the the files in /usr/share/X11/xorg.conf.d/ to load. Below is my gpu-manager.log file .

 last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/4.15.0-22-generic/updates/dkms
Found nvidia module: nvidia-modeset.ko
Looking for amdgpu modules in /lib/modules/4.15.0-22-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:591b
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 10de:1c20
BusID "PCI:1@0:0:0"
Is boot vga? no
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Found "/dev/dri/card0", driven by "i915"
output 0:
card0-eDP-1
Number of connected outputs for /dev/dri/card0: 1
Does it require offloading? yes
last cards number = 2
Has amd? no
Has intel? yes
Has nvidia? yes
How many cards? 2
Has the system changed? No
Intel IGP detected
Intel hybrid system
Nvidia driver version 396.24 detected
Creating /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf

Any ideas how to fix this so nvidia sees a second monitor?

6

Note that OP is on 18.04, and my problem (and solution) is with 18.10. I suspect that with a "newer" nvidia driver the problem is the same on 18.04, comments confirm.

Problem: I'm on Thinkpad p51 which has nvidia quatro m2200 graphics. The laptop has a 4k display and I use external 4k monitor as well. The setup worked nicely on 18.04, but after the upgrade to 18.10 the external monitor was no longer detected. The external monitor wasn't showing neither in the Display settings nor in xrandr. Nvidia drivers are version 390.77.

Solution: Instal and use lightdm:

  1. $ sudo apt install lightdm (or $ sudo dpkg-reconfigure lightdm if it is already installed).
  2. Select lightdm when asked about the display manager selection.
  3. Restart

Context

This seems a bit counter-intuitive, but the https://askubuntu.com/a/1049669/472560 gave a good hint of trying lightdm. Contrary to the linked solution reverting back to GDM didn't help. I need to stay with lightdm.

I've found this post which sheds some light on the issue:

The Ubuntu developer who looks after the ubuntu nvidia-prime package has updated his work for Ubuntu 18.10 (...) Swapping between hybrid and intel-only (either way) works without rebooting, you just need to log out & in again (...) However, it does not work well with gdm3: external monitors don't work because the nvidia driver crashes (...)

Src: Optimus and Ubuntu 18.10: New packages are good but lightdm is required, gdm3 still broken

edit: I've posted a dramatization of the investigation on my blog.

  • 2
    Welcome to Ask Ubuntu and +1 for an excellent first answer! ;-) – Fabby Nov 18 '18 at 19:18
  • 1
    I confirm this fixes the issue. The issue was also introduced in Ubuntu 18.04 LTS. Use: sudo dpkg-reconfigure lightdm to select lightdm instead of gdm3. – cardil Dec 14 '18 at 22:17
  • Thanks @cardil. I’ve added a note on reconfiguration if already installed – Igor Kupczyński Dec 16 '18 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.