1

I have upgraded Oracle virtual box to its newest version 5.2.12. Installed ubuntu 18.04 and I'm unable to mount shared folder to specified location or remove prefix (sf_). Vbox addition are installed. I will set share in Vbox: permanent and automatically reconnect. After that add my user in to vboxsf group

root@data:/home/user# usermod -a -G vboxsf user

by removing prefix I will get this error

root@data:/home/user# VBoxControl guestproperty set /VirtualBox/GuestAdd/SharedFolders/MountPrefix "/"
Oracle VM VirtualBox Guest Additions Command Line Management Interface Version 5.2.12  
(C) 2008-2018 Oracle Corporation  
All rights reserved.

VBoxControl: error: Failed to store the property value, error VERR_PERMISSION_DENIED

by mounting shared folder to specified point same error

root@data:/home/user# VBoxControl guestproperty set /VirtualBox/GuestAdd/SharedFolders/MountDir /home/user/
Oracle VM VirtualBox Guest Additions Command Line Management Interface Version 5.2.12  
(C) 2008-2018 Oracle Corporation  
All rights reserved.

VBoxControl: error: Failed to store the property value, error VERR_PERMISSION_DENIED
root@data:/home/data# 

Any ideas how to fix it or workaround?

1
  • I'm having the exact same problem. Jun 22, 2018 at 18:02

1 Answer 1

3

According to this VirtualBox ticket: https://www.virtualbox.org/ticket/17583

This is intentional as we did some fixes in that area. Please change that parameter from the host side using VBoxManage instead. - pentagonik

I was able to perform this with the same command from the host side via the following command:

VBoxManage guestproperty set [VM Name] /VirtualBox/GuestAdd/SharedFolders/MountPrefix "/"
VBoxManage guestproperty set [VM Name] /VirtualBox/GuestAdd/SharedFolders/MountDIR "/home/user"

After trying this however, my Ubuntu 18.04 VM still mounts it under /media/ with the prefix sf_, so I'm not sure this even works right now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .