6

The Skype app on Ubuntu 18.04 doesn't start when using the Community Theme snap Wayland (communitheme) theme. It automatically takes me to the lock screen

image

Also, clicking on Skype's file sharing icon freezes the app; after a while it shuts down spontaneously. Drag and drop a file for sharing works.

0

3 Answers 3

8

You probably aren't using the latest version of Skype. Try installing the Skype snap package with:

sudo snap install skype --classic 

If that doesn't work try installing the latest version of Skype from the insider channel.

sudo snap install skype --classic --channel insider/stable
3
  • 4
    That doesn't work for me
    – Seaskyways
    Commented Oct 3, 2018 at 16:10
  • The 2nd command with --channel insider/stable works for me now. Thank you! Commented Mar 7, 2019 at 9:34
  • First one worked for me. Commented Jan 28, 2020 at 6:45
1

This is a known issue with XWayland on Ubuntu 18.04.

It will be fixed with a future HWE update (packages linux-generic-hwe-18.04, xserver-xorg-hwe-18.04, xwayland-hwe-18.04). But it remains unclear when this will actually happen.

0

For me worked removing skype and installing it from official skype repository:

  1. Add Skype Linux client repository

     echo "deb [arch=amd64] https://repo.skype.com/deb stable main" | sudo tee /etc/apt/sources.list.d/skype-stable.list
    
  2. Install Skype public key

     wget https://repo.skype.com/data/SKYPE-GPG-KEY 
     sudo apt-key add SKYPE-GPG-KEY
    
  3. Install the apt-transport-https package, if don't have one

     sudo apt install apt-transport-https
    
  4. Install skype itself

     sudo apt install skypeforlinux
    

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .