0

I have Ubuntu 18.0 LTS, I have a internal harddisk of 1 TB but the problem is I am not able to copy or remove anything from it, I checked several questions similar to this but none of them worked. All of them try to change permission of files which I guess does not address my issue. As of now I have tried out these commands and here are their outputs, I am new to linux so please I need detailed answers.

The hard disk is on /dev/sda1

vi /etc/fstab  
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name 
devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb5 during installation
UUID=fe33f56a-d8bc-49d1-bee9-256510fbbc66 /               ext4    
errors=remount-ro 0       1
/swapfile                                 none            swap    sw              
0       0

why I think the file permissions are not a issue is this:

ls -l /media/ace
total 16
drwxrwxrwx 1 ace ace 8192 May 10 19:44  EE9480699480365D
drwxrwxrwx 1 ace ace 4096 May  8 09:23 'New Volume'
drwxrwxrwx 1 ace ace 4096 May 10 06:58 'New Volume1'

Well trying out chmod gives this

chmod 775 'New Volume'
chmod: changing permissions of 'New Volume': Read-only file system

Please help me I require the hard disk space. Cause I am now using the hard disk in which ubuntu is present and I am worried I might run into trouble.

here's the output of

lsblk -fmi | grep -v loop

> NAME   FSTYPE   LABEL           UUID                                 MOUNTPOINT                      SIZE OWNER GROUP MODE

`sda                                                                                                931.5G root  disk  brw-rw----
-sda1 ntfs     New Volume      508C46638C4643A6                     /media/ace/New Volume         931.5G root  disk  brw-rw----
sdb                                                                                                232.9G root  disk  brw-rw----
|-sdb1 ntfs     System Reserved 942A05572A0537AE                                                     549M root  disk  brw-rw----
|-sdb2 ntfs                     EE9480699480365D                     /media/ace/EE9480699480365D    58.1G root  disk  brw-rw----
|-sdb3 ntfs     New Volume      AC201B65201B35B4                     /media/ace/New Volume1        115.7G root  disk  brw-rw----
|-sdb4                                                                                                 1K root  disk  brw-rw----
-sdb5 ext4                     fe33f56a-d8bc-49d1-bee9-256510fbbc66 /                              58.6G root  disk  brw-rw----`

sudo fsck -tntfs /dev/sda1 O/P:fsck from util-linux 2.31.1

nothing else happened even after reboot I tried the command you gave as well

  • please paste the output of this command : lsblk -fmi | grep -v loop – cmak.fr May 23 '18 at 8:04
  • 2
    Did you mount the NTFS partitions with Windows 8 or 10. The fast start up in Windows leaves the hibernation flag set on all NTFS partitions and then the Linux NTFS driver will only mount read only. askubuntu.com/questions/843153/… and askubuntu.com/questions/145902/… Also best not to use spaces with Linux mounts, folder names or file names. I use CamelCase, under_score, or justaname. Spaces just cause issues and must be escaped or quoted. – oldfred May 23 '18 at 16:05
1

A real full shutdown of Windows allows the ntfs partitions to be mounted with R/W perms by Ubuntu. For a full shutdown of windows, hold the SHIFT key as you press the "Shut down" button. You may also disable the 'fast boot' in the windows power control panel.

If you plan to use the 1Tb drive with Ubuntu, you may backup and format the drive with ext4 filesystem. This will give you all the linux security features but the drive wont be readable by windows.

  • This is similar to what I finally did, I resized the partition and now suddenly both are editable (even the ntfs partition). Well, though, the other partition, now, I put it as FAT. – Rishi rao May 24 '18 at 17:29
1

Your filesysystem is mounted read-only. Any write attempt will fail. You need to mount the filesystem in write mode, but first, determine why the filesystem is read-only -- the most likely explanation is that there are errors on it. Run

sudo fsck -text4 /dev/sdb5  

That should fix the errors, and allow a reboot to mount the filesystem in write mode, fixing your problem.

  • That didn't work it just gave O/p: fsck from util-linux 2.31.1 – Rishi rao May 23 '18 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.