31

I recently upgraded to ubuntu 18.04 but I'm facing issues with the wired connection. First off, I must say that the wifi connection is working fine.

When I start my computed I don't even get the wired network icon. Going into the settings/Network parameters, I don't see anything about wired connection (only VPN and proxy).

Thus I tried to understand what was happening and I used a couple of different commands:

~$ lshw -C network 
WARNING: you should run this program as super-user.
*-network                 
   description: Wireless interface
   product: Wireless 8265 / 8275
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: wlp1s0
   version: 78
   serial: 00:28:f8:f8:80:b8
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0- 
22-generic firmware=34.0.1 ip=10.4.26.243 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:144 memory:dc100000-dc101fff
*-network DISABLED
   description: Ethernet interface
   physical id: 2
   logical name: enx3c18a070d46d
   serial: 3c:18:a0:70:d4:6d
   size: 1Gbit/s
   capacity: 1Gbit/s
   capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.9 duplex=full link=no multicast=yes port=MII speed=1Gbit/s

Then I decided to enable the ethernet interface as follows

sudo ip link set enx3c18a070d46d up

The result of the "lshw" command does not show DISABLED anymore. The wired connection icon came back but still no internet connection and now showed the following message

Wired unmanaged

I would be very interested if any of you have an idea about how to solve this problem.

Thank you and have a good day.

Finally, here are the results of a couple of commands (note that ifconfig is obsolete on ubuntu 18.04)

~$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN     mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
link/ether 00:28:f8:f8:80:b8 brd ff:ff:ff:ff:ff:ff
3: enx3c18a070d46d: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc     fq_codel state UP mode DEFAULT group default qlen 1000
link/ether 3c:18:a0:70:d4:6d brd ff:ff:ff:ff:ff:ff

~$ ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state 
UP group default qlen 1000
link/ether 00:28:f8:f8:80:b8 brd ff:ff:ff:ff:ff:ff
inet 10.4.26.243/23 brd 10.4.27.255 scope global dynamic noprefixroute wlp1s0
   valid_lft 42269sec preferred_lft 42269sec
inet6 fe80::11e5:2546:9014:171b/64 scope link noprefixroute 
   valid_lft forever preferred_lft forever
3: enx3c18a070d46d: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc 
fq_codel state UP group default qlen 1000
link/ether 3c:18:a0:70:d4:6d brd ff:ff:ff:ff:ff:ff
inet6 fe80::3e18:a0ff:fe70:d46d/64 scope link 
   valid_lft forever preferred_lft forever

7 Answers 7

44

I had exactly the same problem, but then tracked down the following solution (via this article).

  1. Edit /etc/NetworkManager/NetworkManager.conf (needs to be done with sudo) changing the line managed=false to read managed=true
  2. Restart network manager with

    sudo service network-manager restart
    
5
  • 6
    If this doesn't work for you - keep it, but also for me I had it disabled completely for some reason - to enable ethernet back: see this answer : askubuntu.com/a/909185/277898 for "Ethernet adapter was disable" question - when you don't see any indication when you connect the cable, that's probably the reason :)
    – jave.web
    Jun 13, 2020 at 0:37
  • Like the previous comment, what worked for me is this
    – vineeshvs
    Mar 4, 2021 at 14:18
  • @jave.web you solution worked for me.
    – cyrusbehr
    Mar 5, 2021 at 3:09
  • +1 for @jave.web. I have been searching for at least an hour and the only solution that worked.
    – ssi-anik
    Dec 14, 2021 at 16:28
  • 1
    @ssi-anik I feel you bro, was researching this for hours too :D that's why I posted it.
    – jave.web
    Dec 14, 2021 at 23:30
28

I faced wired unmanaged problem when installing ubuntu-desktop in a Ubuntu 18.04 server installation.

The solution that worked for me is to tell netplan to switch to NetworkManager renderer.

Edit /etc/netplan/50-cloud-init.yaml (or other yaml file you find in /etc/netplan/)

network:
    renderer: NetworkManager # add this line
    ethernets:
        enp2s0:
            dhcp4: true
    version: 2

And then run sudo netplan apply

2
  • Maybe you have to install network manager sudo apt-get install network-manager. Feb 26, 2020 at 22:00
  • thanks a lot worked like a charm ! watch out for indentation
    – masterleo
    May 27 at 16:59
2

This solution(from this article) works for me:

sudo vi /etc/netplan/xxx.yaml add renderer: NetworkManager under version: 2.

Then, sudo service network-manager restart

Now you can find the adapter in setting>networks.

1

I had that problem too and after several days I could resolve it, here is how:

Before I found above regarding edit: "/etc/NetworkManager/NetworkManager.conf" I found that under Bluetooth settings my stationary computer was in Airplane mode. Don't let me comment on how much sense that makes. As that didn't solve the problem I found above suggestion but that still didn't do it.

Fortunately, I have two different routers, one connects via DHCP, the other manual. Accidentally I switched to the manual connected router and the icon changed but still no Internet. I then checked the DNS entries for that connection and found them empty although set to auto. Filling in some DNS resolver got me to the Internet.

That "solution" inspired me to switch the DHCP connection to the other router from auto to manual and to fill in the DNS again. Voila, that did it.

In summary, there seems to be a problem to accept connection data deployed via DHCP.

Background Information

I run 18.04 and 14.04 on the very same computer. As in 14.04, there was absolutely no problem with my connections I was adamant to search elsewhere.

1
  • 1
    Please explain your answer in more detail. I really could not understand anything after the aeroplane mode. Mar 6, 2021 at 7:20
1

Maybe the solution is here: Unmanaged devices Ubuntu 18.04 with installed openbox

sudo systemctl stop networkd-dispatcher
sudo systemctl disable networkd-dispatcher
sudo systemctl mask networkd-dispatcher
sudo apt-get purge nplan netplan.io
sudo apt-get install ifupdown
1
  • after hours and nothing work you script worked Fabrício Pereira thank you for sharing your wisdom
    – Amin
    Nov 9, 2019 at 5:30
0

My issue was similar. I updated to 20.04 server, added Kubuntu Plasma and no network or sound, Still haven't solved the sound problem but within Plasma the Networks icon in the taskbar indicated "Disconnected". "Connections", was empty and so the computer would not connect for updates in spite of the computer being able to access the internet just fine. I added a connection by clicking "Add New Connection" and then I configured it. However, beneath the new listing for the new connection I'd created it said "never used" even after a reboot. I searched here and found part of my solution posted by Afriza N. Arief. In my case "renderer" in netplan.yaml was set to "networkd". In "NetworkManager.conf" "managed" was set to "true". SO my solution was to change "renderer" from "networkd" to "NetworkManager" and that solved the problem of Plasma not recognizing the network adapter/connection which then allowed me to receive updates via the Software Updater.

0

Well, you will need to edit some files and you will be ready to go.

  1. sudo nano /etc/NetworkManager/NetworkManager.conf
  2. Change managed=false to managed=true
  3. sudo nano /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf
  4. Add except:type:ethernet to this line: unmanaged-devices=*,except:type:wifi,except:type:wwan
  5. Restart network manager:sudo service network-manager restart

You can enjoy the wired connection now :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.