1

When doing sudo apt update I get the warnings shown below. This is very annoying and somewhat alarming to see, but why does it even happen?

W: Skipping acquire of configured file 'partner/binary-amd64/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-i386/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en_GB' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/Components-amd64.yml' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-48x48.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-64x64.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-i386' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/cnf/Commands-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-i386/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-amd64/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en_GB' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/Components-amd64.yml' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-48x48.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-64x64.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-i386' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/cnf/Commands-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-updates InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-i386/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-amd64/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en_GB' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/Components-amd64.yml' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-48x48.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-64x64.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-i386' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/cnf/Commands-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-backports InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-amd64/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-i386/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en_GB' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/Components-amd64.yml' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-48x48.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-64x64.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-i386' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/cnf/Commands-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-security InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-amd64/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/binary-i386/Packages' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/i18n/Translation-en_GB' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/Components-amd64.yml' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-48x48.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/dep11/icons-64x64.tar' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-i386' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/Contents-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'partner/cnf/Commands-amd64' as repository 'http://gb.archive.ubuntu.com/ubuntu bionic-proposed InRelease' doesn't have the component 'partner' (component misspelt in sources.list?)
0

It's been awhile since I used Ubuntu (last one I used was 14.04) so not sure if this will work anymore.

Go to settings and choose system, select update server on US or UK and click check updates (in other words, use the non-console way of retrieving updates).

If that won't work, then it's big ouch time. It looks like the components might be misspelt in sources.list or their partner is missing from there which means you have to check the sources.list if changeing the update server won't fix it automatically.

  1. First check the sources.list for misspellings and missing parameters by opening console and typing "sudo nano /etc/apt/sources.list" If you haven't made any changes to sources.list you can just google the default values and copy paste it to the sources.list (make sure to search default sources.list for same release version of distro you have!!!!)
  2. Easiest way to fix this is to backup everything important and re-install the OS.
| improve this answer | |
  • The warnings do not show up when using the non-console way. Apparently they are not harmful, even when running from the console, they are just worrying and seem to indicate that something is not configured correctly at the repository's side. – jpp1 May 24 '18 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.