0

I have a new Lenovo x1c6 which is reported to have 12+ hours battery life by some users.

Mine drains after 4-5 hours, which is roughly the same time I got on my previous 2 y/o $800 Acer laptop with ubuntu 16.04, that's why I suspect the problem is in software.

It also seems like it won't go into a deep sleep/suspend, since a fully charged battery doesn't survive the night (empty after 8-10 idle hours)

I also have this systemd-journald issue that might be related (it happened a few times after resuming from suspend/sleep)

And I've seen in some places people talking about s3 support in ubuntu 16.04, I'm not sure if it's relevant but here is my output:

➜  ~ dmesg | grep -i acpi | grep supports
[    0.206325] ACPI: (supports S0 S4 S5)
[    0.306402] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
➜  ~ cat /sys/power/state
freeze mem
➜  ~ cat /sys/power/mem_sleep
[s2idle]

After using Linux for 8 years, I hope I won't have to switch back to windows.

0

The X1C6 does not support S3 and only supports the S0i3 mode.

More info an solutions here:

https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X1_Carbon_(Gen_6)#Suspend-to-RAM_.28S3.29_not_supported_by_default

  • did you test that solution on ubuntu? – Adam Goldman Jun 26 '18 at 13:49
  • No, I didn't test this myself. I am not using Ubuntu nor having a X1C6 (yet). But I think I read somewhere that someone tried and worked. Sorry for not being able to help more – jhuesos Jun 27 '18 at 7:18
0

Tested this solution yesterday on a laptop with Mint, and it worked perfectly to enable the deep sleep mode.

One little note:

Invert step 11 with step 10: First modify /etc/default/grub. Regenerate grub.cfg with grub-mkconfig. Then add the initrd line into grub.cfg (and don't forget to adapt the linux image to the one used by your system)

0

So, lenovo has fixed this, and now it's controllable directly through the BIOS, as stated in this article:

As of some time before October 2018 ... you can just go to the bios, config, power, and choose “Linux” instead of “Windows” for the sleep settings and everything will be good to go out-of-box. You can probably also turn secure boot back on at this point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.