i've researched google and other fourms for answers and find old and outdated information.

I just attempted Kubuntu install on a 2nd computer (Acer Aspire | M) for testing it before I make the permentant switch from Debian. I select English for everything, I connected to wifi, selected normal installation & Download updates during install.

I then proceded to next screen and selected Guided setup encrypted LVM. Then etner password twice, select correct internal hard drive and continued and confirmed. Then installation went through smooth. It restarted, i removed the usb and pressed enter. Once it displayed Kubuntu logo, please unlock disk sda3_crypt. I entered password. Say's cryptsetup Failed, bad password or options. I tried a number of times, both in which with caps lock on and off. Tried using left shift & right shift different times (as my password has special characters). I even tried using a device I have called OnlyKey which i put the password on this encrypted device (mainly, just so the OnlyKey can 'auto type' it for me) all of which doesn't work. I tried going through install again, same options but just using password 'test' w/out quotes. After it booted back up i could unlock using that password. So, something isn't going right with my password i choose. I prefer to use a strong, longer password where possible. I am using the same password i do on my current pc running debian 9 stretch.

I had also after this (during my first attempted install, before attempting it 2nd time) opened a terminal in live environment and running: sudo cryptsetup luksOpen /dev/sda3 kubuntu when it asked for password, i tried again a number of times with no success. I dumped luks header with - sudo cryptsetup luksDump /dev/sda3 and got similar information to that of my debian machine, aes xts 256, key slot 0 active, the wrest disabled...

I can't seem to understand why I can't use 'more secure' passwords? It doesn't say I can't, but doesn't work if I do. I don't know if for some reason my password was typed differently in installer, but can't see it so i can't verify it, or if its typing it different in the beginning boot process but again i can't see the password so I don't know how to verify. I was going to try manually encrypting the internal hard drive using luksFormat, then install system to it. I dont know exactly how to do that though, as luksFormat erases whats on the device (In this case, the whole system that was just installed), I think the installer would end up formatting this and erasing luks. I see it's got a manual proccess, but i've never done that type of stuff with linux os installers, so i got sort of confused on which partition to even attempt install at.

Any idea what may be going on?

Thank you all for any help :)

  • 1
    Not familiar with kubuntu but are you booting with no splash screen? Initramfs logs might have additional info. – guyfleeman May 22 '18 at 20:19
  • No, I have splash screen. I just now fixed it by doing a trick. I tried install with a short password 'test' without quotes. I could then login after install. So, I decided to run Cryptsetup luksAddKey and added password I initially tried. Then luksRemoveKey to remove password test. I could then boot in with no issue. The long and complicated password I chose during install was what was giving me trouble – computer_guy May 23 '18 at 21:43
  • Would you edit your post or post a solution and accept. – guyfleeman May 24 '18 at 15:17

What I did to work around this issue was during installation, use short and easy password like 'test' without quotes. Then you should be able to boot in. Once in open terminal and run command: sudo cryptsetup luksAddKey /dev/sda3 Then enter a password you wish to encryption volume with (like the one you initially tried during installation.) Then run command: sudo luksRemoveKey /dev/sda3 Then enter short password you entered during install, this will remove that key slot.

Remember to replace /dev/sda3 with the path of the encrypted drive. You can find that out by running: sudo fdisk -l

Then reboot.

Now you can test it by enter password you removed, should be invalid. Enter the one you added and should work no problem. Seems to be an issue with certain length or password requirements not accepted during install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.