0

Checking the content of /etc/X11 dir, I saw that xorg.conf file is missing. Is that normal? I only have xorg.conf.failsafe configuration file with the following lines:

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "vesa"
EndSection

Section "Monitor"
    Identifier  "Configured Monitor"
EndSection

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"
EndSection

Is, the one above, a correct configuration file? Or, I have to restore the xorg.conf file? If yes, how can I do that? The current driver used is:

sudo lshw -c display | grep driver
[sudo] password di michele: 
       configuration: driver=i915 latency=0

and

lspci | grep -E 'VGA|Display|3D'
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] (rev ff)

A few hours ago, after rebooting my OS, I got a black screen with message:

your system is running in low-graphics mode

but after restarting the pc, all strangely returned as before.

Thanks!

marked as duplicate by steeldriver, Panther, karel, Eric Carvalho, user364819 May 31 '18 at 20:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • So, no more needed the xorg.conf file. Well, if the screen with message "your system is running in low-graphics mode" should appears again, what should I do? – michele_ub May 22 '18 at 14:47
  • As you can see from the duplicate, xorg.cong is not needed by most users. From the accepted answer, however, "The xorg.conf does not exist by default any more. You CAN create one though." Some users may desire or need to use a custom xorg.conf to configure options (refresh rate is probably most common) or hardware (touchpad is probably most common here). A better question is, what problem are you having with X and what makes you feel you need an xorg.conf ? If it is not broken, don't fix it. – Panther May 22 '18 at 15:55
  • Well, the problem I encountered was about the message I got after booting my system "your system is running in low-graphics mode". Reading something in internet, I figured out that the first thing to check was the xorg.conf file. That's all. I am afraid it will occour again after a reboot, but I am not sure. – michele_ub May 22 '18 at 16:07