27

Shift+Ctrl+E are invoking the Emoji picker in Ubuntu Bionic (18.04). I use that shortcut in another application. How can I change the shortcut?

1
36

On needs to run ibus-setup and in the "Emoji" tab

IBus Preferences dialog box showing the Emoji tab

....change the shortcut (click on the three dots that are focused in the screenshot). I had to restart my computer after that so that the change would take effect (not sure how to restart IBUS).

11
  • I'm not able to run it it raises an error Traceback (most recent call last): │ File "/usr/share/ibus/setup/main.py", line 33, in <module> │ from gi import require_version as gi_require_version │ModuleNotFoundError: No module named 'gi'
    – Ahmed Eid
    Jul 14 '18 at 17:26
  • I would try installing sudo apt install python3-gi
    – sup
    Jul 14 '18 at 21:06
  • 1
    the who operating system has been acting up lately, I think I'm gonna reinstall it completely. ( thanks for the help).
    – Ahmed Eid
    Jul 15 '18 at 18:04
  • 4
    Try sudo ibus-setup
    – Milso
    Dec 10 '18 at 16:21
  • 2
    sudo ibus-setup works, but the defined keyboard shortcut doesn’t.
    – chmike
    Dec 21 '18 at 10:36
7

To change on the command line in Ubuntu 19.04, you can use gsettings. For example, to remove the shortcut, you can do:

gsettings set org.freedesktop.ibus.panel.emoji hotkey "@as []"

To re-enable to the default shortcut:

gsettings set org.freedesktop.ibus.panel.emoji hotkey "['<Control><Shift>e']"

To change to a different shortcut, run the command just above but change the part <Control><Shift>e to the desired combination.

3
  • 1
    Worked for me on KDE. Nothing else worked: ibus-setup, setting the GTK_IM_MODULE env var for VS Code (the app i had problems with) Aug 18 '19 at 7:00
  • If you have installed VS Code on Ubuntu using Snap, here is a solution for disabling Emoji shortcut: askubuntu.com/a/1269241/229740
    – zardosht
    Aug 22 '20 at 17:56
  • Damn, this other hack still doesn't work for me on Ubuntu 18.04 and VSCode 1.53...
    – Næreen
    Feb 11 at 0:01
1

This is a bug listed here:

https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1885914

The solution that I found is to remove the ibus package:

sudo apt-get remove ibus
sudo apt-get purge ibus

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan and reinstall ibus:

sudo apt-get install ibus

Go to language support and set the iBus method, for user and root

In the terminal for user and root:

ibus-setup

and change the shortcuts in the emoji tab

In the terminal for user and root:

im-config

and set ibus

For user in the terminal:

gedit .bashrc

Include the following lines at the end:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.