1

I am running Ubuntu 18.04 on a HP EliteBook 850 G3. I just did an update in Gnome and restarted. Everything works fine in the login screen, but as soon as I reach the desktop, the keyboard and mouse-clicks do not register. I turned the computer off, and logged in successfully in the Unity environment. I tried "sudo ubuntu-drivers autoinstall", then I restarted and again tried to boot in Gnome. The problem persisted. I also tried enabling the onscreen keyboard at the login screen, but it would not activate in gnome. Any suggestions?

1
  • SOLVED- See github.com/passingthru67/workspaces-to-dock/issues/134 The issue was with the Gnome shell extension 'workspaces-to-dock'. I logged into the Unity environment, and removed the following folder: 'Home/.local/share/gnome-shell/extensions/[email protected]'. I then restarted the computer and logged into gnome. This solved the problem.
    – AFC
    May 23, 2018 at 13:56

2 Answers 2

0

@AFC

Hi there, I'm suffering the same issue in an Ubuntu environment. Gnome 3.28.2 is installed, but I do not get access to any input. Mouse movement will be captured but no clicks and no keyboard entry.

Here is my fix:

sudo apt-get install ubuntu-gnome-desktop

which actually installed gnome 3.28.3 and now I can access my GUI again.

0

maybe it is because of Xserver module lost,I fix it by this: Ctrl+Alt+F1 into the tty mode and

 sudo apt install xserver-xorg-input-all 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .