When my system gets to suspension while the song being played, and got resumed from the suspension, I found my Rhythmbox player running but no sound coming even from the system. I had to suspend it and press the power button to get the sound back. Why is it happening so?

  • 3
    Did you try restarting pulseaudio from a terminal by typing 'pulseaudio -k'? – Takkat Oct 30 '10 at 7:27
  • sounds like an alsa-bug to me. – RolandiXor Oct 30 '10 at 8:34
  • @user3940 'pulseaudio -k' killed the process. I gave the command 'pulseaudio --start' which is of no use. – Vinay Oct 31 '10 at 16:09
  • 3
    To start pulseaudio after '-k' you need not do anything - it usually restarts automatically. If not then 'pulseaudio -D' would be the command to restart the daemon. If 'pulseaudio -k' had no effect to bring your audio back then at least we know it's not a crashed pulseaudio server we have here. – Takkat Oct 31 '10 at 20:20

Try turning off your sound device (click on volume control, click sound preferences, and then go the hardware tab, click the device, and choose off).

Then press alt+f2, and type gksu alsa force-reload.
This should reload your audio.
Now turn back on the device (Set it to the previous choice before you turned it off).

  • I did what you mentioned. Worth a try. Still the problem exists. – Vinay Oct 31 '10 at 16:13
  • Roland Taylor's solution worked for me. – user8329 Jan 4 '11 at 12:36
  • 1
    This one worked for me as well... Googling lead me down a lot of different and futile paths with this issue, and while nothing I've read yet suggests a fix (although I would love one if anyone can suggest something permanent), this at least saves me a reboot. Thanks : ) – Steve Jan 10 '13 at 20:36

What worked for me was asking pulseaudio to exit:

pactl exit

This causes the audio device not to be in use anymore. Then I reloaded the module for my sound card:

sudo rmmod snd_au8830 && sudo modprobe -v snd_au8830

Finally, I restarted pulseaudio:


I also re-uploaded the sample I was using for the bell sound. Unfortunately, any applications which had connected to the old instance of PulseAudio had to be reinitialized somehow (for example, a Web browser with a YouTube video had to have their page reloaded). It's a pain in the behind, but at least it's repeatable, and so far always works. I have this in a shell script so that it's easy to do after resuming from suspend. The biggest hurdle may be figuring out your sound card's driver.

This happens to be for an HP Pavillion a1257c with an Aureal Vortex PCI sound card. This same sound card in a Precision 670 had no problems coming back from suspend, same OS, so it would seem to me to be definitely specific combinations of hardware which can cause difficulty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.