I've just tried out Kubuntu 18.04 and somehow I cannot start Goldendict to system tray on start up. It's so weird because when I run goldendict in terminal or from dash, it starts to system tray without problem. But only on start up it shows the whole window with a very long number (screenshot below).

enter image description here

  • 1
    If you want goldendict to autostart use System Settings > Startup and Shutdown > Autostart > Add Program In the GUI that appears, look under Education > Miscellaneous. I don't know why you see this weird long string in the search box by default. Did you set up your dictionaries correctly? Also, with goldendict not running, have you tried renaming ~/.goldendict to ~/.goldendict.bak and then starting goldendict? Perhaps something in your ~/.goldendict is corrupted?
    – DK Bose
    May 22, 2018 at 11:09
  • 1
    Yes, that's the problem. I remove the .goldendict directory and now everything is fine. Except one thing, that it always drops down the File menu everytime it runs, but I can workaround by hiding the menu with Ctrl+M May 22, 2018 at 15:00
  • Well, now it happens again, deleting .goldendict only helps one time. May 23, 2018 at 2:37

2 Answers 2


I got this problem as well. If you dig into it deeper you'd notice goldendict starts (the same wrong way) even being removed from autostart! The only way to stop it from start on login is

  1. remove from autostart
  2. kill (not just close into tray, but kill like pkill goldendict)
  3. relog/reboot

Why? Because the default (before you ever touch the setting) KDE start behavior is "restore previous session" (at least in 18.04)! And when it "restores" previouly running apps it supplies "-session XXXXXXXXXXXXXXXXXXX_XXXX_XXXXX" argument to those. Try running goldendict -session hello and you'll see it will start not into systray and with "hello" word in the search field. Here is how it did start for me on login and here is what I saw in pstree.

Now to the fix. Go System settings/Startup and Shutdown and set On Login=Start with an empty session.


I tried it and on relog there only was a black screen (probably because I left with Ctrl+Alt+Bksp). To fix that I Ctrl+Alt+F2 to a virtual console and changed loginMode to default in ~/.config/ksmserverrc (it says "default" but the meaning is "empty session").

Thanks for posting your question so I didn't feel lonely dealing with it!


This can also be fixed on KDE by addinggoldendict to the line starting with excludeApps in the file ~/.config/ksmserverrc; for example


See https://github.com/goldendict/goldendict/issues/1041 for a similar discussion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.