I am trying to install jupyter notebook on Ubuntu 18.04 using pip3. However, I run into this error:

" Cannot uninstall 'pyzmq'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall."

I tried the command below but still no success.

pip3 uninstall pyzmq

Any help would be appreciated.

3 Answers 3


What I did to solve a similar problem is that I updated the pyzmq first while ignoring previous installations, using the command below:

pip3 install --ignore-installed pyzmq

Then, I installed the jupyter notebook with the following command:

pip3 install jupyter


This probably has to do with the pip version you are using.

You can use pip 9 instead:

sudo -H pip3 install pip==9.0.3

And than uninstall/install what you need:

sudo -H pip3 uninstall pyzmq

I had to run this (python 2.7):

sudo apt-get remove python-zmq 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.