2

I want to install SILE Typesetter which depends on HarfBuzz (libharfbuzz-dev). The libharfbuzz-dev available from repositories is version 1.0.1 (released 2015), while the latest version available from HarfBuzz's website is 1.7.6 (released 2018). How can I create libharfbuzz-dev package from the available new source of HarfBuzz? Or how can I use the available source for building SILE, without creating the package libharfbuzz-dev?


I basically want to build SILE for myself but I certainly am interested in learning how to prepare a package (-dev as well as the regular package) for distribution.

  • @Melebius I have edited the question, adding the specific details. Please expand on how I can "compile and link the library" when building SILE? – Asim May 22 '18 at 9:44
  • 1
    The "harfbuzz (1.7.6-1ubuntu1)" build files are in Ubuntu 18.10 Cosmic. You can add deb src [url] cosmic main to the sources.list and possibly build the harfbuzz_1.7.6..._amd64.deb packages with $ apt-get -b source harfbuzz=1.7.6-1ubuntu1 – Knud Larsen May 22 '18 at 20:44
  • @Asim did Knud comment solve the problem? If no please update the question. – user.dz Oct 27 '18 at 11:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.