0

I have an upstart configuration file that's worked on my Ubuntu 16.04 VPS in the past (I reverted to upstart for 16.04 using this method here.)

After reinstalling the server for a clean slate and using the same methods of successfully installing upstart the service says running but the process does not actually start. I've tried completely wiping the Ubuntu VPS clean and trying again, but it didn't work. I tried simply stopping the upstart and restarting it, but it still didn't work. It continues to say running, but it doesn't actually run. Extremely strange since it's worked in the past on a Ubuntu VPS using the exact same conf file and methods of reverting systemd to upstart. Conf file looks like this:

description "daemon"

start on runlevel [23]
stop on shutdown

exec sudo -u root prd/build/release/src/paradigmd --no-console

post-stop exec sleep 30

respawn
respawn limit 5 30

paradigmd is the daemon.

Any help would be appreciated. Should I just forget about upstart and use systemd for this instead? If so what are the exact steps I would need to do to achieve what I'm going for here.

2
  • forget about upstart and use systemd . I do not think upstart is supported on 16.04, so while you can try it, support is limited, at best. See wiki.ubuntu.com/SystemdForUpstartUsers
    – Panther
    Commented May 22, 2018 at 4:33
  • I don't know why the process shows up as running but I see some general issues in the invocation in the exec stanza: 1) start on runlevel suggests a system job (as opposed to a user job), so sudo is unnecessary and sudo -u root looks fishy. 2) prd/build/release/src/paradigmd is a relative path. Did you research the working directory of the Upstart init process that will serve as an anchor for relative paths? If you're unsure, is it worth the trouble to use a relative path instead of a less fallible absolute path? Commented May 22, 2018 at 8:53

1 Answer 1

0

You have followed a tutorial on reverting to Upstart despite a bold warning that it may render your system unusable. Now that your system is broken, it's a good time to re-consider the choice to use Upstart.

Even if you get this working, your system may quit working during a maintenance upgrade, because things expect systemd to the init system on Ubuntu 16.04, not Upstart.

It looks like you have rather simple needs. Your time is better spent converting your Upstart script to a systemd config file. There's a page on systemd for Upstart users here:

https://wiki.ubuntu.com/SystemdForUpstartUsers

As long as you are installing things scratch, consider starting over with Ubuntu 18.04, the newest LTS release.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .