1

I recently made the jump from 16.04 to 18.04. I did a fresh install, including encrypting my entire drive, but now I am having problems that I did not have in 16.04.

As a little background, I have an external USB HDD from which I run Ubuntu on a desktop. I also have a laptop which uses the internal HDD. Everything was working great with 16.04. That is, I could boot, run, everything was fine. I could connect my USB HDD to my laptop, give the encryption password, it would mount, and I could copy files between the drives. Remember, all of the drives in question are encrypted boot drives.

There were some issues with this setup, though. The main problem was solved by making sure each encrypted HDD used a unique volume group name. Once I got that, everything was fine for a long time.

Then I installed 18.04 on my laptop (encrypted drive). Worked great, even after I changed the volume group name.

Sadly, I can no longer connect my 16.04 HDD to my laptop (laptop is running 18.04). I get the small, unencrypted, boot partition to mount and I see the main encrypted partition in the sidebar, and I even get prompted for the password when I click on the main partition. However, once I enter the password it says that I cannot mount that drive and the drive disappears from the sidebar (I am doing all of this with the GUI).

I installed 18.04 on another USB HDD and my 18.04 laptop cannot mount the 18.04 USB HDD either. My 16.04 USB HDD can mount the 18.04 USB HDD. My 18.04 USB HDD cannot mount my 16.04 USB HDD.

Short version: Even when everything has unique a volume group name, 18.04 with full disk encryption seems no longer able to mount another boot drive (16.04 or 18.04) with full disk encryption.

What could I do to fix this?

  • Have you tried using the command line, more likely to show an error and give us a clue... askubuntu.com/questions/63594/… – ostergaard May 28 '18 at 7:42
  • @ajostergaard I followed the steps on your link and now I can see a folder in /media with the encrypted drive name. However, when I open that folder, it is empty. No error messages during the whole process. – John May 29 '18 at 2:56
  • That's annoying... Sorry but I can only suggest you try the mailing list at the bottom of gitlab.com/cryptsetup/cryptsetup – ostergaard May 29 '18 at 4:31
0

I found a solution, so I am posting it. I had not tried this solution so it might or might not have been possible when I posted the question above.

I plug in the extra external encrypted boot drive. Nothing shows on the left bar of the file manager, except the small boot partition. The big encrypted partition never shows. Here are the steps.

  • Step 1: Launch Disks (from Dash for example)
  • Step 2: Select the extra encrypted boot drive
  • Step 3: Select the locked partition on the right, click the unlock button
  • Step 4: Enter the password
  • Note: It still does not show up on the left side bar of the file manager (where other USB drives show)
  • Step 5: On the left side bar of the file manager, select "Other Locations"
  • Step 6: Under "On This Computer" you should see the encrypted partition of the extra drive, open it

That's it. It works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.