0

So here´s what happened:

1 - I have an Imac and was trying to downgrade it from High Sierra to El Capitan by trying to force its installation manually. That corrupted the OS system files and i could not start the Imac.

2 - Then i created a bootable Ubuntu 18.04 LTS into a pendrive and am booting the Imac that way. While Ubuntu does list the drive, it cannot mount it. Therefore, i cannot backup the files to try and reinstall the mac OS again.

So, How do i get to mount the Apple SSD in order to backup my files ?

It´s an 1.0 TB Disk Apple SSD GPT partition, and the imac does not have access to internet, so anything i might need to install in order to fix this i have to get from another computer and use a flashdrive to transfer to the mac.

Hopefully i made myself clear enough, not a code expert so looking forward to the simplest solution to this.

Thanks in advance!

EDIT: Here are some things i've tried:

sudo fdisk -l
Disk /dev/sda: 931.9 GiB, 1000555581440 bytes, 1954210120 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt


Device      Start        End    Sectors   Size Type
/dev/sda1      40     409639     409600   200M EFI System
/dev/sda2  409640 1954210079 1953800440 931.7G unknown

ubuntu@ubuntu:~$ sudo mount /dev/sda2 /mnt/mydrive mount: /mnt/mydrive: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program, or other error.

root@ubuntu:~# sudo mount -o force -t hfsplus /dev/sda2 /mnt/mydrive mount: /mnt/mydrive: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program, or other error.

`root@ubuntu:~# sudo blkid /dev/sda1: LABEL="EFI" TYPE="vfat" PARTLABEL="EFI System Partition" /dev/loop0: TYPE="squashfs" /dev/loop1: TYPE="squashfs" /dev/loop2: TYPE="squashfs" /dev/loop3: TYPE="squashfs" /dev/loop4: TYPE="squashfs" /dev/loop5: TYPE="squashfs" /dev/loop6: TYPE="squashfs" /dev/sdb1: LABEL="Ubuntu 18.04 LTS amd64" TYPE="iso9660" PTTYPE="dos" /dev/sdb2: SEC_TYPE="msdos" TYPE="vfat" /dev/sda2: PARTLABEL="Customer"

ubuntu@ubuntu:~$ chmod 777 /mnt/mydrive chmod: changing permissions of '/mnt/mydrive': Operation not permitted

root@ubuntu:~# dmesg | tail [15973.657824] hfsplus: unable to find HFS+ superblock [16676.299567] hfsplus: unable to find HFS+ superblock [16678.938532] hfsplus: unable to find HFS+ superblock [16692.359656] hfsplus: unable to find HFS+ superblock [16698.538832] hfsplus: unable to find HFS+ superblock [17648.524471] usb 1-6: USB disconnect, device number 12 [17906.084770] hfsplus: unable to find HFS+ superblock [18851.170154] hfsplus: unable to find HFS+ superblock [20157.836826] hfsplus: unable to find HFS+ superblock [20311.030734] hfsplus: unable to find HFS+ superblock

0

Start gnome-disks there you can get the device adress /dev/XXX. (For example: /dev/sda1).

Then you can try to mount it in the terminal. If you fail, you can post the errormessage and we can help you better ;-)

mkdir mnt_ssd
sudo mount /dev/XXX mnt_ssd/


Edit: It seems your superblock has some issues.

You can try to mount with an offset

sudo mount -t hfsplus -o ro,offset=$((512*409640)),sizelimit=$((512*1953800440)) /dev/sda /mnt/mydrive

If this wont work, i recommend to do a copy of the disk with sudo dd if=/dev/sda2 of=/somewhere/you/have/enough/space/disk.dd

Source: Can't mount HFS+ drive, bad superblock?

  • 1
    sudo mount /dev/sda2 mnt_ssd/ returned the following: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program or other error – justme May 21 '18 at 22:27
  • Neither options suggested worked. Tried several other things suggested in other threads but no luck at all. Unfortunately, had to format the SDD and reinstall it by losing all the data. Thanks everyone for the help though! – justme May 22 '18 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.