Recently I installed Ubuntu 18.04. Installing Conky Manager with these commands failed with "Dependency is not satisfiable: realpath".

sudo apt install conky-all
cp /etc/conky/conky.conf ~/.conkyrc
sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt update
sudo apt install conky-manager
wget https://launchpad.net/~teejee2008/+archive/ubuntu/ppa/+files/conky-manager_2.4~136~ubuntu16.04.1_amd64.deb
sudo apt install gdebi
sudo gdebi conky-manager*.deb

Do you know how to resolve the dependency on "realpath"?

  • 3
    There has been no active development to conky-manager since 2016, and apparently one program realpath that was available in the repros then isn't available any longer. It will not be easy to recreate it either - see e.g. the discussion here. You may contact the developer through his Launchpad page.
    – Jos
    May 21, 2018 at 20:49
  • 1
    And you shouldn't, generally speaking, attempt to install software (from ppas or otherwise) that aren't available for your OS version.
    – DK Bose
    May 22, 2018 at 0:39
  • 1
    have installed conky on ubuntu 18.04 and it works fine! I don't understand why you want to install it via external ppa. It works fine with standard packages.
    – abu_bua
    Jul 5, 2018 at 15:41
  • 1
    @abu_bua Likely there's an expectation (correct or otherwise) that Conky Manager will shorten or eliminate the learning curve that accompanies attempts to customize Conky.
    – Zeiss Ikon
    Aug 14, 2018 at 16:33

8 Answers 8


You can install it with a .run file from GitHub.

For 64 bit:

wget --no-check-certificate https://github.com/teejee2008/conky-manager/releases/download/v2.4/conky-manager-v2.4-amd64.run
chmod +x conky-manager-v2.4-amd64.run
sudo ./conky-manager-v2.4-amd64.run

For 32 bit:

wget --no-check-certificate https://github.com/teejee2008/conky-manager/releases/download/v2.4/conky-manager-v2.4-i386.run
chmod +x conky-manager-v2.4-i386.run
sudo ./conky-manager-v2.4-i386.run

Install realpath first and then install Conky Manager.


  • Artful is 17.10, right? If realpath is in 17.10 but not in (bionic) 18.04, there's probably a good reason.
    – Zeiss Ikon
    Aug 14, 2018 at 16:35

Donwload realpath in here, download conky manage in here install with GDEBI or dpkg :

sudo dpkg -i packagename.deb

I have written a post about how to install the conky manager on ubuntu 18.04, along with the error that I found on this site. May be useful.


I've worked on building conky manager for 4 hours and I'm very experienced in building packages.

But building conky manager was a trip down a road I don't wont to go again LOL.

I highly advise whoever wants to install it on Kubuntu or Ubuntu 18.04 to go with answer 4,

It ran flawlessly on Kubuntu and Ubuntu 18.04 fully updated. I just had to try it.

But I also need to say that if anyone was wanting to learn how to build packages from sources, that you would learn a lot from building conky manager and have a lot of fun too.


Or from GitHub:


  • 1
    "answer 4" is ambiguous. which author's answer do you recommend? Jan 22, 2020 at 16:09

a tentative answer:

1° install conky:

sudo apt-install conky

2° download realpath: link to realpath

3° download the conky manager: this is the link

4° install realpath and then conky:

sudo dpkg realpath_8.26...(the rest of the name you can copy paste in the terminal)
sudo dpkg conky...(id.)

5° then:

sudo apt -f install

6°launch conky manager from activities.

hope this works for you.

leave long and prosper.


I'm using debian and this commands worked for me.

sudo apt-get install conky-all
sudo apt-get install realpath
wget https://github.com/teejee2008/conky-manager/releases/download/v2.4/conky-manager-v2.4-amd64.deb
sudo dpkg -i conky-manager-v2.4-amd64.deb

I followed the first reply but then I got the error:

conky-manager: error while loading shared libraries: libgee-0.8.so.2: cannot open shared object file: No such file or directory

Then from

ldd /usr/bin/conky-manager

I got

libgee-0.8.so.2 => not found

and I solved with the command:

sudo ln -s /usr/share/conky-manager/libs/libgee.so.2 /usr/share/conky-manager/libs/libgee-0.8.so.2

For those interested, I've managed to compile conky-manager and make it run on Raspbian/buster with the following:

sudo apt install build-essential valac libjson-glib-dev libgtk-3-dev libgee-0.8-dev imagemagick p7zip p7zip-full
git clone https://github.com/teejee2008/conky-manager.git
cd conky-manager
make && make install

This should work on ubuntu 18.04 too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.