8

I'm on Ubuntu 18.04, 64 bit.

I downloaded the .deb from the Steam website. I tried installing with Ubuntu Software. It didn't seem to work. I tried installing via the terminal, using various commands and combinations of commands.

sudo dpkg -i ~/Downloads/steam_latest.deb
sudo apt-get update
sudo apt --fix-broken install
sudo apt-get install -f

In Ubuntu Software, it currently lists both "Steam" and "Steam installer" as installed applications. When I go to Steam and click "launch", nothing happens. When I open the show applications menu from the desktop and type "Steam", a program named Steam, with the Steam logo, appears. I click it; nothing happens.

How do I diagnose what is wrong?

How do I figure out why Steam is not running on my computer?

EDIT – in response to Organic Marble, here is the code output to the command steam

Repairing installation, linking /home/elen/.steam/steam to /home/elen/.local/share/Steam
Running Steam on ubuntu 18.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/elen/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib/i386-linux-gnu/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
/home/elen/.local/share/Steam/steam.sh: line 444: no match: ssfn*
  • To format a code block, type it in, select it, and press the {} button in the editor. – Chai T. Rex May 22 '18 at 0:03
  • You can gather valuable information by opening a terminal emulator window and typing steam <enter> in it. There will almost certainly be error messages printed out; copy them and add them to your question. – Organic Marble May 22 '18 at 0:26
  • Alright, I added the output to the command steam…. – Elen Sila May 22 '18 at 13:37
  • 2
    Who keeps downvoting this question and its answers? This is a legitimate issue with a fresh Ubuntu + Steam install, It just hangs on the first run. – ASalazar May 27 '18 at 17:34
7

Running 'steam' on console stalled also for me on a fresh install. This is the sequence of actions that made it work for me.

  1. Deleted ~/.steam
  2. Deleted ~/.local/share/Steam
  3. Ran 'steam' in a terminal. Pressed Control+C when it stalled
  4. Ran '~/.local/share/Steam/ubuntu12_32/steam' in a terminal. It autoupdated and finished normally.
  5. Ran 'steam' again. It started normally.

This happened to me on Ubuntu 17.04 and 17.10, and after this it always worked fine, although the binary of step 4 was different. It seems like an issue with their initial setup.

  • 1
    This worked for me! – lucasvscn Jun 16 '18 at 22:31
  • On 18.04, this worked as well - and I only needed steps 1+2 and start steam afterwards. then the update is running and steam is working again. – Julian Egner Nov 22 '18 at 21:33
2

Well Mate I've had a similar trouble, Hope this helps,

1 - Remove the Valve package:

`sudo apt purge steam-launcher`

2 - Delete the repository if it hasn't been removed with the package: ( Don't worry If the Terminal doesn't find your answer, that means that this step was redundant)

`sudo rm /etc/apt/sources.list.d/steam.list`

3 - Reload the sources list:

`sudo apt update`

4 - Install Steam from the repos:

`sudo apt install steam`

Solution found at this post: https://askubuntu.com/a/864430/850719

Tested at Ubuntu 18.04 fully updated, at 17.08.2018

  • Absolutely. The Valve package stopped working for me at 16.04. I've been using Ubuntu version since, and it's been all good. – Jacek Ciolek Jul 21 '18 at 18:36
1

Ubuntu 18.04: Once you successfully uninstalled your current Steam (all directory related to steam) please open a terminal and type the following in order to have a fresh and clean installation:

sudo add-apt-repository multiverse

Once you're right the output should be:

'multiverse' distribution component enabled for all sources


Then install steam (using the terminal this is important in order to see potential error messages)

sudo apt install steam
sudo apt update

Once the installation is successfull, just type steam

steam

Here either it works and then have fun ! Or you have the following error message:

tar: This does not look like a tar archive
xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
find: ‘/home/$USERNAME/.steam/ubuntu12_32/steam-runtime’: No such file or directory

If you do have this message, don't give up and run:

mkdir "/home/$USERNAME/.steam/ubuntu12_32/steam-runtime"

It should now works !

0

The client itself doesn't open until you click on its icon in the system tray, near the date & Time (top right). After that, it appears to function normally, as I found at https://steamcommunity.com/app/221410/discussions/0/2906376154318030934/

0

just had this issue this link resolved it for me launchpad

/usr/bin/steam --reset
find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" \) -print -delete
~/.local/share/Steam/ubuntu12_32/steam
0

I made it work installing both the 390 64-bit driver and this 32-bit library:

sudo apt-get install libnvidia-gl-390:i386

Not the answer you're looking for? Browse other questions tagged or ask your own question.