2

After switching between multiple screens, I am now locked in the following situation:

  • I can see that the Terminal-program runs, as I can see it with AltTAB
  • Yet, when I switch to it, there is no Terminal-window visible.
  • However, I get the menu bar on top, and there, I can see under menu [Tabs] that my terminal tabs are still living
  • I can even access my tabs by switching to full screen, there also CntrlPageup works as expected.
  • I can also say AltSPACE to get the menu for window manipulation options, but they all do not do anything noticeable, except "Minimize" which leaves full screen.
  • But once I leave full screen, the windows are again invisible.

Is there a way how I can get my Terminal-tabs back to normal, visible windows?

  • it may be just a graphical bug? – B. Amine May 21 '18 at 13:36
  • If you can close the running applications gracefully, a reboot may help to get things correct again. – sudodus May 21 '18 at 13:38
  • @sudodus: I really hope to be able to restore the existing terminals. – false May 21 '18 at 14:01
  • @B.Amine: My suspicion: I moved the windows into a place where they are inaccessible – false May 21 '18 at 14:02
  • Which version (16.04 LTS or 18.04 LTS or ...) and which flavour (standard Ubuntu, Kubuntu... Ubuntu Server,... Xubuntu) are you running? What do you mean by 'multiple screens'? Is it an option to reboot, or must you continue to run the computer? – sudodus May 21 '18 at 18:18
3

Here is a partial full fix which was inspired by this answer.

Pressing CtrlAltNumpad 1, the size of the fullscreen window is temporarily reduced to a reasonably sized window without the Window decoration attached to the Terminal window. However, when selecting another window and then going back to Terminal, the Terminal remembers that it is fullscreen and gets fullscreen again. Now, CtrlAltNumpad 1 no longer works, as the windows "believes" it is in that corner already. So I do

CtrlAltNumpad 7CtrlAltNumpad 1

to make it visible again. Another bug feature is used to kind-of undo the original one.

But wait ..., then I select [View] -> [Show Menubar] and I got the original Window decoration back, and the window can now be selected normally. Everything saved!

| improve this answer | |
  • +1. Thanks for sharing your solution :-) – sudodus May 22 '18 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.