I'm having problems installing vim on my upgraded Ubuntu. When I try to install vim:
sudo apt-get install vim
I get this error saying I have broken packages.
The following packages have unmet dependencies. vim : Depends: libpython3.6 (>= 3.6.4~rc1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
I tried fixing this with
sudo apt-get update sudo apt-get -f install
My python version is 3.6.5. So I am rather confused that something is missing for vim. Because before my upgrade to 18.04 I had vim installed and it worked fine.
dpkg --get-selections | grep hold
Doesn't show any held packages either.
But I still get the same error. Any ideas?
I fixed the issue by downgrading my python packages to the version vim was requesting. Thanks for the help. I solved the issue with
sudo aptitude install -f vim