0

I have a dell inspiron 5567 laptop and am dual booting windows 10 and ubuntu 16.04. I have been trying for a while now to get the integrated graphics card working, which windows sees as a Radeon R7 M440 but ubuntu shows Topaz XT [Radeon R7 M260/M265]. I have tried vgaswitcheroo here: https://help.ubuntu.com/community/HybridGraphics , but it doesn't do anything. When I tried what is suggested by the first post here vgaswitcheroo not selecting discrete card it simply shut the screen down until I forced a shutdown. PRIME (https://wiki.archlinux.org/index.php/PRIME) seems to work, except that I tested it using glmark2 and got significantly better performance from the integrated card than the discrete card, with the integrated card achieving 1076 FPS on the first test while discrete card only got 478 FPS. sudo lshw -C video shows the discrete card as using the amdgpu drivers.

From the output if glmark2 (given below), it seems to me that the discrete card is working but does not work with the intel card very efficiently. Is there any way to make the machine only use the discrete graphics card without using VGAswitcheroo? or have I used vgaswitcheroo improperly? I am still reliatively new to ubuntu so any help is appreciated.

The full output of sudo lshw -C video is:

  *-display               
   description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 02
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:280 memory:de000000-deffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff
  *-display
   description: Display controller
   product: Topaz XT [Radeon R7 M260/M265]
   vendor: Advanced Micro Devices, Inc. [AMD/ATI]
   physical id: 0
   bus info: pci@0000:01:00.0
   version: c3
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi bus_master cap_list rom
   configuration: driver=amdgpu latency=0
   resources: irq:281 memory:c0000000-cfffffff memory:d0000000-d01fffff ioport:e000(size=256) memory:df200000-df23ffff memory:df240000-df25ffff

xrandr --listproviders shows:

Providers: number : 2
Provider 0: id: 0x64 cap: 0x9, Source Output, Sink Offload crtcs: 3 outputs: 2 associated providers: 1 name:modesetting
Provider 1: id: 0x3f cap: 0x4, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:Unknown AMD Radeon GPU @ pci:0000:01:00.0

The first few results from glmark2 are as follows: glmark2 gave:

=======================================================
    glmark2 2014.03+git20150611.fa71af2d
=======================================================
    OpenGL Information
    GL_VENDOR:     Intel Open Source Technology Center
    GL_RENDERER:   Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) 
    GL_VERSION:    3.0 Mesa 17.2.8
=======================================================
[build] use-vbo=false: FPS: 1076 FrameTime: 0.929 ms
[build] use-vbo=true: FPS: 1223 FrameTime: 0.818 ms
[texture] texture-filter=nearest: FPS: 1176 FrameTime: 0.850 ms
[texture] texture-filter=linear: FPS: 1206 FrameTime: 0.829 ms
[texture] texture-filter=mipmap: FPS: 1172 FrameTime: 0.853 ms
[shading] shading=gouraud: FPS: 1082 FrameTime: 0.924 ms
[shading] shading=blinn-phong-inf:^C

DRI_PRIME=1 glmark2

=======================================================
    glmark2 2014.03+git20150611.fa71af2d
=======================================================
    OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   AMD ICELAND (DRM 3.18.0 / 4.13.0-41-generic, LLVM 5.0.0)
    GL_VERSION:    3.0 Mesa 17.2.8
=======================================================
[build] use-vbo=false: FPS: 478 FrameTime: 2.092 ms
[build] use-vbo=true: FPS: 506 FrameTime: 1.976 ms
[texture] texture-filter=nearest: FPS: 470 FrameTime: 2.128 ms
[texture] texture-filter=linear:^C
  • Turns out the card was working, but would only be used for fullscreen applications and when specifically invoked using DRI_PRIME=1. It worked for a video game that I installed, but I could not get it to work for the windowed application I needed at that time. – J. Long Jul 25 at 4:36
0

The product string can be mismatch with what it should be. I think its fine as long as string shows same product family. Hybrid cards indeed complicated stuff and when its about the play games at Steam, selecting right card can be so buggy. As an example Dota with Hybrid RADV didnt work with Mesa 17.2 and below, at least for me.

Well first try blacklist radeon module from kernel. How to blacklist radeon module?

Try Oibaff's Mesa stacks, and if there no problem appear use them.

Install radeon-profile with its daemon. https://github.com/marazmista/radeon-profile Its a usefull control center for your AMD card. Set Performance/High mode your card. You can OC too, as i always do.

Last use glxinfo | grep "OpenGL" for GLStrings, its more proper way yet produce same result.

  • Apologies for the late respons e. I have blacklisted both radeon and amdgpu and installed the oibaf drivers from launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers by adding the repository and running sudo apt-get dist-upgrade, and restarted, but now the graphics card shows up as "unclaimed" and xrandr only shows the intel card as a provider – J. Long May 29 '18 at 1:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.