4

After installing Ubuntu 18.04 on my new Dell Laptop, I'm wondering wether it is possible to speed up the booting process. Here is some basic information:

systemd-analyze:

Startup finished in 3.879s (kernel) + 28.444s (userspace) = 32.323s
graphical.target reached after 28.001s in userspace

systemd-analyze blame:

    11.425s dev-sda3.device
     10.386s plymouth-quit-wait.service
      8.797s plymouth-start.service
      6.751s dev-loop1.device
      6.719s dev-loop2.device
      6.599s dev-loop3.device
      6.574s dev-loop4.device
      6.565s NetworkManager-wait-online.service
      6.551s dev-loop5.device
      6.524s dev-loop7.device
      6.499s dev-loop8.device
      6.277s fwupd.service
      6.075s snap-gnome\x2dcalculator-154.mount
      5.736s snap-gnome\x2dcharacters-86.mount
      5.687s snap-gnome\x2d3\x2d26\x2d1604-64.mount
      5.656s snap-gnome\x2dsystem\x2dmonitor-39.mount
      5.621s snap-gnome\x2dlogs-31.mount
      5.245s dev-loop0.device
      2.778s udisks2.service
      2.604s networkd-dispatcher.service
      2.529s grub-common.service
      2.457s snapd.service
      2.187s gpu-manager.service
      2.057s accounts-daemon.service
      2.052s ModemManager.service
      2.017s snap-gnome\x2dsystem\x2dmonitor-36.mount
      1.946s apport.service
      1.681s systemd-udevd.service
      1.641s bolt.service
      1.618s dev-loop11.device
      1.574s dev-loop6.device
      1.573s dev-loop12.device
      1.552s dev-loop9.device
      1.543s keyboard-setup.service
      1.508s dev-loop10.device
      1.403s NetworkManager.service
      1.385s bluetooth.service
      1.379s snap-gnome\x2dcalculator-167.mount
      1.370s rsyslog.service
      1.206s systemd-tmpfiles-setup-dev.service
       929ms thermald.service
       843ms systemd-remount-fs.service
       835ms systemd-journald.service
       813ms dev-mqueue.mount
       810ms dev-hugepages.mount
       802ms sys-kernel-debug.mount
       756ms systemd-sysctl.service
       706ms snap-gnome\x2d3\x2d26\x2d1604-59.mount
       690ms systemd-fsck@dev-disk-by\x2duuid-408C\x2d72C2.service
       687ms snap-gnome\x2dcharacters-69.mount
       660ms snap-gnome\x2dlogs-25.mount
       648ms polkit.service
       644ms snap-spotify-13.mount
       635ms systemd-modules-load.service

and systemd-analyze critical-chain:

     graphical.target @28.001s
     └─multi-user.target @28.000s
      **└─kerneloops.service @24.171s +21ms**
        └─network-online.target @24.169s
         **└─NetworkManager-wait-online.service @17.603s +6.565s
          └─NetworkManager.service @16.197s +1.403s**
           └─dbus.service @15.305s
            └─basic.target @14.841s
             └─sockets.target @14.841s
              **└─snapd.socket @14.799s +41ms**
               └─sysinit.target @14.790s
                **└─systemd-timesyncd.service @14.580s +210ms
                  └─systemd-tmpfiles-setup.service @14.181s +366ms**
                    └─local-fs.target @14.177s
                      └─run-user-120.mount @18.907s
                        └─swap.target @13.501s
                          **└─dev-disk-by\x2duuid-91bef5fa\x2dfe6b\x2d441f                 \x2d92c3\x2dcf857dacef7e.swap @13.355s +145ms**
                            └─dev-disk-by\x2duuid-91bef5fa\x2dfe6b\x2d441f\x2d92c3\x2dcf857dacef7e.device @13.354s 

Does anyone have any suggestions on how to speed up the booting process?

  • 1
    I'd say 32 seconds is as good as it gets with Gnome3 and systemd. You could try to remove snaps and to disable services, but I am not sure you'd want it. – mikewhatever May 20 '18 at 12:31
  • Can you provide your HW specs? Especially CPU, RAM and HDD type. Your simple “Dell Laptop” info does not say much about performance… – Melebius May 21 '18 at 14:18
  • @ WinEunuuchs2Unix Yes @Melebius Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz, DDR4, SATA. Is that sufficient or do you need the full output of lshw? – Dominik B. May 21 '18 at 14:48
1

18.04 with no swap partition

There is a glitch where Ubuntu 18.04 is boots slow when there is no swap partition. To circumvent this edit /etc/default/grub and search for the line with LINUX and add noresume after quiet splash. It will look something like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noresume"

Then save the file and run:

sudo update-grub
  • 1
    Unfortunately, this did not change the booting time. – Dominik B. May 21 '18 at 14:53
  • @DominikB. I revised the answer. – WinEunuuchs2Unix Jun 20 '18 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.