1

I am trying to install MonoDevelop version 5.4.1.7 so that I can use it with Mono 5.4.1.7.

First I tried installing Mono 5.4.1.7 by following the instructions here http://www.mono-project.com/download/stable/ except replacing stable-bionic with stable-xenial/snapshots/5.4.1.7 (there are no 5.4 snapshots for Bionic). This worked:

$ sudo apt install mono-complete
[...]
mono-complete is already the newest version (5.4.1.7-0xamarin5+ubuntu1604b1).

Then I tried to do the same thing with MonoDevelop. I followed the instructions here http://www.monodevelop.com/download/ but I replaced vs-bionic with vs-xenial/snapshots/5.4.1.7. This didn't work:

$ sudo apt update
[...]
All packages are up to date.
W: Conflicting distribution: https://download.mono-project.com/repo/ubuntu stable-xenial/snapshots/5.4.1.7 InRelease (expected stable-xenial/snapshots/5.4.1.7 but got xenial)

$ sudo apt install monodevelop
[...]
Package monodevelop is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'monodevelop' has no installation candidate

I also tried changing stable-xenial to xenial, and sudo apt update no longer throws an error but it still can't install MonoDevelop.

Why doesn't this work? How can I install MonoDevelop version 5.4.1.7 on my system?

  • Try replacing vs-xenial/snapshots/5.4.1.7 with only vs-xenial, then sudo apt update again. What is the output of apt-cache showpkg monodevelop after doing that? – Aryo Adhi May 23 '18 at 19:00
  • When I do that, it installs MonoDevelop 7.5.0.1254-0xamarin1+ubuntu1604b1 but it also adds Mono sources for 5.10, which I don't want. apt upgrade wants to change my Mono to 5.10.1.47-0xamarin4+ubuntu1604b1. Also, this version of MonoDevelop does not launch with Mono 5.4 installed. – Aaron Franke May 27 '18 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.