1

I'm trying to install Ubuntu 18.04 LTS. But when I boot into "Try Ubuntu" and also when I boot into "Install Ubuntu", my mouse movement works, but no mouse clicks, no keyboard input. I can't switch to console, etc.

Hardware

Operating system name: Microsoft Windows 10 Home
Version: 10.0.17134 Build 17134
Further operating system description: Not available
Operating system manufacturer: Microsoft Corporation
System name: SCHLEPPI5
System manufacturer: Acer
System model: Aspire A717-71G
System type: x64-based PC
System SKU 000000000000000000
Processor: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz, 2808 MHz, 4 core(s), 8 logical processor(s)
BIOS version/date: Insyde Corp. V1.10, 22.08.2017
SMBIOS version: 3.0
Version of the embedded controller: 1.10
BIOS mode: UEFI
Motherboard manufacturer: KBL
Motherboard model: Not available
Motherboard name: Motherboard
Platform role: Mobile
Safe start state: On
PCR7 configuration extension required for display
Windows directory: C:\WINDOWS
System directory: C:\WINDOWS\system32
Start device: \Device\HarddiskVolume1
Locale: Germany
Hardware abstraction level: Version = "10.0.17134.1"
User name: SCHLEPPI5\freak
Time zone: Central European Summer Time
Installed physical memory (RAM): 8.00 GB
Total physical memory: 7.89 GB
Available physical memory: 3.06 GB
Total virtual memory: 13.4 GB
Available virtual memory: 7.08 GB
Size of the swap file: 5.50 GB
Swap file: C:\pagefile.sys
Kernel DMA Protection: Off
Virtualization-based security: Not enabled
Device encryption support: Extension required for viewing
Hyper-V - VM Monitor Mode Extensions: Yes
Hyper-V - SLAT extensions (Second Level Address Translation): Yes
Hyper-V - Virtualization enabled in firmware: Yes
Hyper-V - Data execution prevention: Yes

  • this looks like some hardware issue. ple tell more about the hardware (usb/wireless/laptop...?) – cmak.fr May 19 '18 at 9:51
  • It's Acer Laptop i bought a week ago. It uses wireless. Mouse is USB, Keyboard is integrated. Im installing using USB. – Uwe Pfeifer May 19 '18 at 9:58
  • I've edited the post with hardware information. – Uwe Pfeifer May 19 '18 at 10:00
2

Does your computer use an NVIDIA? I also have an acer aspire. Tried to install Ubuntu 18.04 LTS from an bootable usb, got similar problems, no mouse moving etc. Reinstalled 17.10 and then had the same problems, until i changed the NVIDIA driver. Could upgrade to 18 from there, but kept getting all sorts of problems like this again, because the drivers where changed with the upgrade. After research other people fixed these problems by installing the proper driver. Unfortunately, i haven't been able to fix it. I suspect this could explain your problem. I've decided to go for 16.04 LTS and wait a bit longer, to see if this will be fixed in newer updates.

  • it has an nvidia. im downloading the image and will try it. 17.10 though. – Uwe Pfeifer May 19 '18 at 11:49
1

Same issue here. Mouse will move, but no Input is possible.

Gnome 3.28.2 is already running and still not having access to mouse clicks and keyboard. Seems like a bug in Gnome 3.28.2

Fixed it with:

sudo apt-get install ubuntu-gnome-desktop

which actually installed Gnome 3.28.3 and now I can access my GUI again.

  • 1
    @Graham Changed my comment and how i solved this issue. – Hirschferkel Sep 6 '18 at 7:58
  • That's great thanks. The review system worked as two further reviewers have recommended OK after your edit. – Graham Sep 6 '18 at 9:37
  • @Graham Ah o.k. still confused, why I still get the delete flag for the comment... – Hirschferkel Sep 6 '18 at 9:46
  • Don't worry about it now. Your edit helped it survive the review process. See here: meta.askubuntu.com/questions/18190/… – Graham Sep 6 '18 at 10:34
1

Interesting. I had a similar issue with a few old hardware combos during installation. The underlying issue seems to trigger an USB over-current condition on all ports whether in use or not anything was plugged in...which of course screws with all the USB and PS/2 detection processes. Hmmm...I wonder if it could be an underlying issue with VSB power monitoring on USB 2.0 ports?

Or at least that is what onscreen text log said a couple times when I was changing video cards from PCI to PCIe. All USB and PS/2 devices appear working well on other computers and even the same computer under different OSes (and versions of Ubuntu). Note: I was trying both types of keyboard and mouse plugged directly into motherboard ports. Also Windows 7 installed easily with no HW changes and using same exact type of USB media (evidence that its Ubuntu issue not bad hardware).

Kinda of funny that the video looks good but the problem non-intuitively shows up as input device human interface recognition error after installation customization starts. Not sure this moves topic into bug reports -- but if so the following is still a "good to know" workaround until its fixed. Plus there is probably a better command line, installation kernel option workaround answer rather than just start swapping video cards until your input devices work.

It may well be a rule that old 775/771 CPUs circa pre-2009 (Pentium D, Core 2, Xeon 54xxL) plus odd or old video cards can lead to newer Ubuntu distributions not recognizing keyboards and/or mice (USB and/or PS/2). Especially if booting off USB media. Failing video cards included ATI VT-RAD7K 64P (Radeon 7K 64MB PCI), an MSI Nvidia GT210 PCIe, Quadro FX580 PCIe and others (none requiring extra video power plug). Note that at most 3 low power devices (4GB flash drive,keyboard, and trackball/mouse) were plugged into USB ports. Also most of the video cards in failing combos were low power. I think the Radeon 7K is like 15W and the GT 210 is slow with passive heatsink. 425W power supply should be sufficient and I doubt Windows is significantly better at power management.

What eventually worked was a HD 5770 PCIe with external power plug with original PS/2 keyboard and mouse. Also was using MS-7514 v1.0 (P45-Neo3)motherboard with L5430 FPGA 771 CPU conversion to install to a 2.5" 160GB Seagate laptop SATA drive. But by then I had also removed an Intel PCIe dual 100 port network card (intended to build firewall-router) and burned Ubuntu LTS 18.04 yet again though on same model of USB stick (and replace Windows 7).

Final note original Ubuntu media seems to work fine in my main Windows 10 machine. Even did a bad block check with Rufus while imaging the stick to install pfSense 2.4.4 on the now verified hardware. (Whole process started when the old 3.5" 60GB IDE drive with pfSense installed burned up and I decided to upgrade CPU-motherboard-memory and optimize hardware ethernet interfaces for throughtput.)


P.S. Even after successful Ubuntu LTS 18.04 install, switching to the following video cards resulted in great video but non-responsive keyboard and mouse clicks (pointer itself moved around fine just as it did during failed install):

e-GeForce 6200TC (128MB PCIe...but needs some caps replaced),

Switching to the following cards WORKED after full install completed: Quadro FX 580 PCIe (failed during install) MSI Nvidia GT210 PCIe (failed during actual install) ATI VT-RAD7K 64P PCI (Radeon 7K 64MB --failed during actual install)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.