0

I am using ubuntu 16.04 on my laptop dell inspiron 5577 gaming.My touchpad has not been working since i installed ubuntu though the touchpad works fine in the pre installed windows 10.I have tried the solution from Touchpad under 16.04 not working and it doesn't even detect my touchpad,i have tried many solutions i don't know what to do now.It even has few other problems like the battery indicator is not showing and the laptop doesn't even shutdown properly.Please help.

0

I've had this exact laptop with the exact same problem(among others) with ubuntu 16.04.

I'm not entirely sure if this is what fixed it but all I did after countless non working solutions offered by others on the internet was:

  • Upgrade the kernel to the very latest out at the time. I used UKUU to make it easy.

  • Rebooted(it automatically selects the newer kernel at boot)

and voila! My touchpad was working again.

Also, check to make sure in the Hardware Drivers section if you have any proprietary drivers that need to be installed.

That generally solves a few issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.