1

I want to open netease-cloud-music(a music player).But some errors happened.

Downloads> sudo apt-get install libvlc5        
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libvlc5 is already the newest version (4.0.0~rc1~~git20180518+r75817+138~ubuntu18.04.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
➜  Downloads> sudo netease-cloud-music    
netease-cloud-music: error while loading shared libraries: libvlc.so.5: cannot open shared object file: No such file or directory

enter image description here

I have tried some ways like
https://www.reddit.com/r/RetroPie/comments/5jpeq2/a_lil_help/
But it doesn't effect.
What should I do?
Thanks!

libvlc5:
  Installed: 4.0.0~rc1~~git20180518+r75817+138~ubuntu18.04.1
  Candidate: 4.0.0~rc1~~git20180518+r75817+138~ubuntu18.04.1
  Version table:
 *** 4.0.0~rc1~~git20180518+r75817+138~ubuntu18.04.1 500
        500 http://ppa.launchpad.net/videolan/master-daily/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     3.0.1-3build1 500
        500 http://mirrors.aliyun.com/ubuntu bionic/universe amd64 Packages
  • Please copy & paste text into your question. Pictures of text are much harder to read. I would also suggest adding apt-cache policy libvlc5 and its output to the question. – guiverc May 19 '18 at 7:47
  • 1
    I can open the player a few days ago, but it errors today. – Espylapiza May 19 '18 at 7:50
  • If I enter whereis libvlc.so.5 on my desktop (& raspb.pi), I get told "libvlc.so: /usr/lib/x86_64-linux-gnu/libvlc.so.5" - please confirm you get the same. (the pi gave same location, but not identical obviously as its not x86) – guiverc May 19 '18 at 12:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.