1

When I try to run nvidia-settings to switch GPUs, the following output shows up:

ERROR: NVIDIA driver is not loaded


ERROR: Error querying enabled displays on GPU 0 (Missing Extension).


ERROR: Error querying connected displays on GPU 0 (Missing Extension).

** Message: 22:22:22.703: PRIME: No offloading required. Abort
** Message: 22:22:22.703: PRIME: is it supported? no

ERROR: Unable to open file '/home/uruwi/.nvidia-settings-rc' for writing.

I've rebooted several times and reïnstalled the nvidia drivers to no avail. I also tried running sudo nvidia-xconfig, but the generated file causes problems.

Edit 1/?: sudo modprobe nvidia fails because of an "exec format error", if that information is useful. dmesg gives the following lines:

[ 1066.385988] PKCS#7 signature not signed with a trusted key
[ 1066.395098] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 00000000873cc009, val ffffffffc2c20430

Edit 2/?: I tried running the following commands:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt purge nvidia*
sudo apt install nvidia-390

Now nvidia-settings gives the following error:

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

If I run nvidia-xconfig and try to start the X server, this gets put into the log.

Edit 3/?:

$ uname -a
Linux uruwi-HP-ENVY-x360-m6-Convertible 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Edit 4/?: Tried using bumblebee but optirun fails because... it can't load the driver.

Edit 5/?: Great, I edited the bumblebee configuration but now optirun gives a Cannot access secondary GPU, secondary X is not active. error.

Edit 6/?: Manually installed the nvidia driver and I still can't load it (with more debug info):

$ sudo modprobe nvidia
modprobe: ERROR: could not insert 'nvidia': Exec format error

Edit 7/?: Managed to get a loadable nvidia driver by temporarily switching cc to gcc 7.3.0 before installing. However, Cinnamon crashes now, probably because X can't initialise any GLX extension. Here's Xorg.0.log.

Edit 8/?: Reïnstalling xserver-xorg-core as shown here solves the X error, but the problem is that now I can't use the nvidia drivers.

Edit 9/?: Invoking nvidia-xconfig makes glsanity report the proper driver for the NVidia card, but when I try to actually run a program under optirun, I get an X BadMatch error on GLX / X_GLXSwapBuffers.

Edit 10/? but I hope it's 10: realised that having CodeXL installed is causing apt purge to not really purge packages. Trying purging everything NVidia-related again and reïnstalling the drivers.

Edit 11/I was wrong: did that and same problem as before.

Edit 12/infinity: Xorg --configure complains about not finding fbcon, making me slam the desk hard enough to reboot my machine. (fixed by installing xserver-xorg-video-fbdev)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.