0

I just did a clean install of 16.04 and I'm having an issue with the software center. The funny thing is I installed Ubuntu a few weeks ago on this same machine and didn't have the issue but I had to wipe it out and reinstall and I'm having issues now. When I open up the software center, it will stay open for a few seconds and just close, no crash dialog or anything. When I run gnome-software from terminal I get the message "Segmentation fault" when it shuts down and that's it. No other information

  • For some reason, Ubuntu is crashing Ubuntu software because it (Ubuntu Software) is accessing memory that it is not allowed to access it, more information here : stackoverflow.com/questions/3200526/… – singrium May 19 '18 at 1:24
  • I see. Is there a way to fix it? Or is it a bug with the gnome-software? – graffixnyc May 19 '18 at 1:48
  • A segmentation fault is almost always due to a bug in the program where it occurs. Just to make sure, run it from the terminal as root, if the problem remains, then it is mostly a bug. – singrium May 19 '18 at 2:43
  • Thanks, When I run it as root, it stays open, however it doesn't fully load (imgur.com/a/zWjI2UF) and I get this message in the terminal (gnome-software:4871): GsPlugin-WARNING **: could not lookup cached macaroon: Error calling StartServiceByName for org.freedesktop.secrets: Timeout was reached – graffixnyc May 19 '18 at 3:15
  • Try reinstalling the software center with sudo apt install gnome-software --reinstall – subtleseeker May 19 '18 at 7:06
0

It looks like a bug (more information).
The proposed solutions :

  • Solution 1:

sudo killall gnome-software
sudo rm -r ~/.local/share/gnome-software

This will first, end (kill) the process of gnome-software if it is running, then remove gnome-software from the ~/.local/share folder, then it will be recreated automatically when you launch it (gnome-software or ubuntu-software) again.
Now launch ubuntu-software or gnome-software from the Unity Launch Button.

  • Solution 2:

sudo apt-get autoremove gnome-software
sudo apt-get install gnome-software -f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.