21

I installed Ubuntu 18.04 amd64 desktop on Asus Eeepc 1015px, but it hangs on booting. The last message is 'Started User Manager for UID 120'.

I managed to boot up in recovery mode and finished the installation with 'sudo apt-get upgrade', but nothing has changed.

Does anybody know how I can tackle it?

Thanks in advance, Newton.

3

5 Answers 5

10

The same happened to me and the reason was no left space on the disk.

In the case that it could be your problem too, try the following:

During the stucked booting, press alt+F3 to enter the second terminal, then login. Now you should be in your home folder. Some functionality could be unavailable because of the lack of space. Now try to remove some big files by rm command. You can check the current status of the disc usage by command df -h. After there is enough space on your disk, just enter reboot and the system should boot normally.

1
  • The login works but then I am prompted again with login. Any ideas?
    – desmond13
    May 3, 2020 at 22:33
9

Enter Ubuntu through recovery mode, from the main menu choose the first option, the one about the restart, give always ok and you should arrive to the desktop; once in, update and upgrade everything and after that open a terminal and type sudo nano /etc/gdm3/custom.conf , once the file is opened, in the [daemon] section uncomment WaylandEnable=false , save and restart, problem fixed ;-) .

4
  • 3
    ubuntu-18-04-hangs-on-booting-with-message-started-user-manager-for-uid-122 . I tried this didn't work, it still hangs!
    – Kitcho
    Jul 4, 2018 at 11:39
  • @kitcho Try installing lightdm based on this answer askubuntu.com/a/1037192/60869
    – rahi
    Jul 7, 2018 at 15:44
  • thanks, this just solved a very similar problem I had in a Cloud Environment, based on a QEMU-KVM virtualization layer (even when in my workstation's QEMU-KVM it did not fail)
    – xCovelus
    May 8, 2019 at 9:29
  • ubuntu-18-04 with regolith-desktop did this today after a reboot. This solution worked perfectly even though I have no idea how or why the issue happened and why this fixes it. Could you post in the answer please why disabling Wayland resolves the issue?
    – vanboom
    Jan 28, 2020 at 0:41
3

I found that using lightdm the nomodeset parameter was the key to fixing my issue with 18.04

Nomodeset: How to get in once via temporary grub change

You can add the grub configuration parameters if you hold right shift at bootup and press e to edit Ubuntu parameters. You need to replace quiet splash with nomodeset. Then hit ctrl x to save and continue.

Lightdm: How to put in the permanent fix

Once in, open a terminal and type sudo apt install lightdm, then sudo dpkg-reconfigure lightdm, then sudo reboot

Please refer to this amazing guide for more details and screenshots!:

My computer boots to a black screen, what options do I have to fix it?

5
  • I did all of the above. Now not even alternate tty starts. Login prompt appears for 1sec and then a black screen with a blinking cursor is all i see, even when i start using e and nomodeset. It power downs on pressing power button though.
    – madD7
    Aug 24, 2019 at 18:17
  • @madD7 did you follow the rest of the guide? Aug 25, 2019 at 16:11
  • Yes. I followed the rest of the guide. i have now permanently disabled gui boot.
    – madD7
    Aug 28, 2019 at 7:08
  • I don't have a quiet splash parameter in my Ubuntu parameters, any ideas?
    – desmond13
    May 4, 2020 at 8:04
  • This solved it for me with Ubuntu 18.04 Apr 13, 2021 at 5:23
2

I had the same symptoms: "started User Manager for UID xyz" then lost of display using a NVIDIA GEFORCE GT 1030 on Ubuntu 18.04. In my case, the driver was just not installed.

To fix the issue, I removed the GT 1030, booted using the integrated video card and enabled telnet service. I then put the GT 1030 back, booted the computer, opened a Telnet session from a different computer and installed NVIDIA Driver using command line instructions. In found these instructions to be very helpful: https://www.linuxbabe.com/ubuntu/install-nvidia-driver-ubuntu-18-04

4
  • This works for me.
    – galian
    Jul 14, 2020 at 5:58
  • sudo ubuntu-drivers devices
    – galian
    Jul 14, 2020 at 6:05
  • sudo apt install nvidia-driver-version-number, e.g. sudo apt install nvidia-driver-440-server, this is recommended by ubuntu.
    – galian
    Jul 14, 2020 at 6:05
  • reboot: sudo shutdown -r now
    – galian
    Jul 14, 2020 at 6:06
0

Did you change /etc/passwd Perminssion?

I recently change the permission of /etc/passwd, hoping nobody will be able to glance it for finding the users in the machine, so I change permission to only root. after some time I turn off my Machine and what I'm seeing Started User Manager for UID 121.

I restarted my machine two time, when nothing happened, I put out my phone and start searching for solution.

Causes:

  • Disk Full

  • Upgrading fails

    and many more.. didn't help me all the above solution.

I started thing what happened, suddenly an idea came to my mind, It may be the cause of /etc/passwd.

I selected the recovery Mode in the Grub, set the file permission to sudo chmod 644 /etc/passwd

And sounds like Wow, because of unable to be read during login.

You should try the above valuable solution if you didn't play around with passwd

Not the answer you're looking for? Browse other questions tagged or ask your own question.