1

I've recently installed 18.04 and the only problem I haven't been able to solve is that my USB Audio Interface (Steinberg UR12) doesn't work.

At first, I had it plugged into a USB 3.0 PCI card; only the inputs were detected, not outputs. When plugged into one of the mainboard's USB ports (2.0 and 3.0 work), all inputs and outputs are detected correctly, but nothing actually works (no sound from speakers, no sound from microphone).

When audio is being played, I can see activity in pavucontrol, but I can't hear anything. Also, in alsamixer, the device shows "This sound device does not have any controls.".

Screenshot: alsamixer "This sound device does not have any controls"

So I can't unmute channels or adjust volume, which is suggested on many websites. I've also tried playing sound using aplay, without success (it says it's playing, but no sound can be heard).

Another thing I've tried is patching the snd-usb-audio module's quirks-table.h file as suggested in a post about a similar interface, also without any luck (note that I have replaced the product and vendor IDs with the correct ones from lsusb).

I've also tried to use the interface in live sessions of 16.10, 16.04 and some version of 14, without any luck.

Command outputs:

Let me know if I can provide anything else helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.