2

I would like to use the Colemak keyboard layout. In previous versions of Ubuntu (16, 17), it has been available as an input source. I just installed 18.04 LTS (into VMWare player) and Colemak is not available. I would have expected it to look exactly like this blog post, which indicates it was there for at least one user. But I only have a handful of English sources and "Other", for which the only Colemak options are Filipino and Norwegian layouts!

I'm working around for now with setxkbmap us -variant colemak, but that doesn't persist across logins.

(For bonus points, how I would I also change the default keyboard layout for the login screen? Currently I need to type my password in QWERTY...)

2

Yes, it's available in Settings -> Region & Language. Click the + button, select English (United States), and pick it from the sub menu.

If you are on a single user system, the input sources you add through the GUI should automatically (at next reboot) be made available also on the login screen.

  • I have two systems – on one, I can choose the input source in the login screen, on the other, I cannot. – MPi Jun 20 '18 at 20:40
  • @MPi: The difference can probably be seen if you check the contents of /etc/default/keyboard on the two systems. – Gunnar Hjalmarsson Jun 20 '18 at 20:56
  • I don't see colemak either. – Quang Mar 1 at 20:16
  • After more searching, setxkbmap us -variant colemak worked for me. superuser.com/questions/227727/… – Quang Mar 1 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.