0

My new Acer Laptop just arrived (A315-51-5647) and after installing Ubuntu Budgie 18.04 I'm having problems with the touchpad. For some minutes it worked fine, but now when I left right click it acts as if I left clicked. Once in a while it works normally, but 99% of the time it's bugged. I didn't install any exotic package or made any suspicious configuration (on the touchpad I only switched from two finger to edge scrolling and turned off natural scrolling). With a USB mouse it works fine. I tried everything I could to no avail, please help and thanks already!

EDIT: Even if I switch the primary button to the right button both work as primary buttons.

When I xinput --list-props "SynPS/2 Synaptics TouchPad"

Device 'SynPS/2 Synaptics TouchPad':
    Device Enabled (143):   1
    Coordinate Transformation Matrix (145): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (298): 1
    libinput Tapping Enabled Default (299): 0
    libinput Tapping Drag Enabled (300):    1
    libinput Tapping Drag Enabled Default (301):    1
    libinput Tapping Drag Lock Enabled (302):   0
    libinput Tapping Drag Lock Enabled Default (303):   0
    libinput Tapping Button Mapping Enabled (304):  1, 0
    libinput Tapping Button Mapping Default (305):  1, 0
    libinput Natural Scrolling Enabled (280):   0
    libinput Natural Scrolling Enabled Default (281):   0
    libinput Disable While Typing Enabled (306):    1
    libinput Disable While Typing Enabled Default (307):    1
    libinput Scroll Methods Available (282):    1, 1, 0
    libinput Scroll Method Enabled (283):   0, 1, 0
    libinput Scroll Method Enabled Default (284):   1, 0, 0
    libinput Click Methods Available (308): 1, 1
    libinput Click Method Enabled (309):    0, 1
    libinput Click Method Enabled Default (310):    1, 0
    libinput Middle Emulation Enabled (287):    0
    libinput Middle Emulation Enabled Default (288):    0
    libinput Accel Speed (289): 0.000000
    libinput Accel Speed Default (290): 0.000000
    libinput Left Handed Enabled (294): 0
    libinput Left Handed Enabled Default (295): 0
    libinput Send Events Modes Available (265): 1, 1
    libinput Send Events Mode Enabled (266):    0, 0
    libinput Send Events Mode Enabled Default (267):    0, 0
    Device Node (268):  "/dev/input/event7"
    Device Product ID (269):    2, 7
    libinput Drag Lock Buttons (296):   <no items>
    libinput Horizontal Scroll Enabled (297):   1

EDIT 2: This command solved the problem

gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

I found it here on AskUbuntu, but I lost the link. Anyways I hope it helped

  • You should post your solution as an answer instead of an edit if possible – dsSTORM May 18 '18 at 22:38
0

This command solved the problem

gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

I found it here on AskUbuntu, but I lost the link. Anyways I hope it helped

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.