3

I want to change the owner of a folder. The path to to that folder is /mnt/8A30AA8B30AA7DB7/Books. I want to take the ownership of that folder to change the permissions. The folder currently belongs to root. I tried the following connamds but none seem to work.

  1. chown apoorv_potnis -R Books
  2. sudo chown apoorv_potnis:apoorv_potnis -R Books
  3. sudo chown apoorv_potnis:apoorv_potnis -R /mnt/8A30AA8B30AA7DB7/Books
  4. sudo chown -R apoorv_potnis: /mnt/8A30AA8B30AA7DB7/Books

The terminal displays chown: changing ownership of '/mnt/8A30AA8B30AA7DB7/Books': Read-only file system and other files in the folder but does not actually change the ownership. Whenever I check the properties of that folder or the sub-folders, the owner is shown to be root and I cannot change the permissions or delete any file of that folder. How can I take the ownership of the folder? I'm using Ubuntu 18.04 with dual boot Windows 10.

2

As commented by user7547272 and oldfred, I disabled Fast Startup and hibernation on Windows 10, ran chown and chmod. Then I followed what was written in this post and my problem was solved.

1

It sounds as though the directory is mounted as Read Only, instead of Read Write. Unmount the directory, remount it as R/W Review the man pages on mount for further details.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.