2

level not an expert in linux

Dear all,

I just installed ubuntu 18.04 on a ThinkCenter Lenovo M910x (SS HD) alongside windows 10. I did so using a usb stick (created using unetboot) and live mode.

Remark Already during the live mode the machine was very slow.

Nevertheless I managed to click and follow the steps for the install.

Remark I didn't check the third party thing and the install took less time than usual.

The computer booted into ubuntu but without any grub. This ubuntu version was also very slow. After restarting several times to try to boot (from usb) and use boot-repair, I couldn't access the bios at any of these attempts and ended up without Ubuntu not even able to prompt me with the screen I log into, just a screen with ubuntu written at the bottom.

I can log in into tty.

So I haven't seen grub, not able to access bios to boot from usb or windows.

Anyone has an idea ? I haven't been able to work for a whole day now. Thanks for your help in advance.

  • I have the same issue. It looks like the keyboard is disabled at shutdown and enabled again after grub starts ubuntu so it is unresponsive when the computer restarts. The only way to enable the keyboard at startup is to remove the power plug first. – axxis Feb 6 '19 at 17:24
0

The Grub menu appears when press & hold the shift key on boot

Keep hitting Shift until you see "Grub Loading Message"
After the message, hold the Shift down until the menu appears.

Windows 10 does not shutdown but hybrid-shutdown and, then, F1 and F12 keys to Bios have no effect. Real shutdown of Win10 is available with shift+click on shutdown button

See here how to disable this Windows 10 'feature' : https://www.tenforums.com/tutorials/4189-turn-off-fast-startup-windows-10-a.html

  • hitting shift doesn't seem to work, I see a black screen, I keep hitting shift but end up on the ubuntu login screen. My monitors are using displayport so maybe there is something preventing them to show the message at the beginning – ThingsHappen May 18 '18 at 14:08
0

Fastboot must be activated on the BIOS, it blocked the GRUB to be executed

You must have a reset button next of your power alimentation, so use something like a pencil and on it a few seconds when your computer is shutdown; you will have a menu, select the BIOS (and don't forget to turn off the "fasboot enable" option for the GRUB)

With Lenovo computer, you can't access at BIOS by pressing Fn or Escape button, it's this reset button that do the work

EDIT : this tip works only for portable computer, I have answered a little too fast (because I don't see that the Lenovo M910x wasn't a portable)

  • I don't seem to find the reset button on this model :-( – ThingsHappen May 18 '18 at 14:09
  • Have you tried the tutorial on Lenovo website? askubuntu.com/questions/197459/… – damadam May 18 '18 at 14:15
  • No worries, yeah it's a desktop ! I tried to change the values in the grub file in case somehow the grub was working but nothing really changed – ThingsHappen May 18 '18 at 14:55
0

Technically, the BIOS is always the first to start - any OS is loaded afterwards, so it shouldn't be your Ubuntu installation. Imho, you have to look for the correct bios key - usually anF or DEL key. Just looked it up and it should be F1 for your computer (source: https://support.lenovo.com/de/en/solutions/ht500217 ).

Maybe it could also be because of your hardware? look here -> https://forums.lenovo.com/t5/ThinkCentre-A-E-M-S-Series/M910x-Tiny-access-BIOS/td-p/3909542

If you have access to the hardware, you could also try to unplug the drive to verify being able to access the BIOS.

0

If Shift does not provide access to the GRUB menu, try Esc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.