11

I migrated to Ubuntu 18.04 a week ago due my VPN needs, and it works perfectly except that the OS is too slow and I sometimes can't open any applications until I reboot.

My laptop has good hardware (a seventh-generation Intel Core i7 and 8 GB of RAM), but my memory utilization is 6 GB or more when I run Skype, Slack, and Firefox together.

Is this normal?


vmstat 10 4 output:

procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 7  0      0 898448  56344 3007108    0    0   148   215  420 1246 12  4 78  7  0
 7  0      0 887908  56376 3059492    0    0     1    68 4231 13951 33 10 56  0  0
 7  0      0 943000  56416 2996092    0    0     0   102 4199 14527 32 10 58  0  0
 3  0      0 934796  56448 3003276    0    0    23   103 4397 14711 34 10 55  1  0
8

High memory utilization is quite normal on a Linux system. Ubuntu is no exception. It uses unused memory for disk caching to increase system performance. You can find a good explanation with some further detail here.

Slow speed is often more a function of DE weight (gnome is heavy) than distribution version. LXDE and XFCE are very light and can make even low quality or somewhat obsolete hardware deliver acceptable performance.

Other things that can drastically reduce system speed are failing or poorly performing storage devices, dusty or otherwise compromised cooling systems can lead to overheat conditions that will cause modern processors to reduce speed in an attempt at self preservation.

The output of commands like dmesg and grep "error" /var/log/syslog can also provide clues as to what's going wrong in a system that doesn't perform as expected.

This is by no means a complete list, but it should give you some clues, and may very well lead you to new and more focused questions.

The memory leak bug you mention appears to now be squashed, However your vmstat output doesn't appear to indicate that you are effected by that bug.

According to your vmstat output your CPU is spending the majority of it's time idle, so the bottleneck isn't there. My best guess given the information available is either storage device or cooling system problems.

  • @HelderJúnior Always happy to help. Since your a new member here, I should let you know that the way we say thanks here is by accepting(clicking the check mark) next to the answer that helped us the most and or upvoting. upvoting will be the next privilege that you receive as your reputation increases here. – Elder Geek Jun 14 '18 at 13:17
  • how ironic is that the optimization process makes the OS slow? – André Marcondes Teixeira Oct 4 '18 at 17:30
  • @AndréMarcondesTeixeira I'm not sure which optimization process you are referring to. If you have a question about that feel free to ask and provide a link to the process you are referring to to help provide context. – Elder Geek Oct 4 '18 at 21:11
3

I had the same issue, and it resolved after I removed my google account that I had added in the settings. Initially, after looking up online, I ran the systemd-analyze blame command that showed some network related processes hogging the cpu. So it is quite likely that google account is the culprit.

1

Some common reasons you can't open any applications are:

  1. The system didn't notice you tried to open the application. Try to open the application once more (don't do this repeatedly or you might suddenly have the application open 25 times or something).
  2. The system might be really, really busy. Leave the computer alone for literally five minutes right after you try to open the application and see if the application opens.
  3. Virtual memory might be almost completely full. Check whether RAM and swap space are completely filled by running free -m or top in a terminal.
  4. Your disk might be failing. Run an Extended SMART test in the Disks application. It'll take several hours to complete the test, but you can use your computer while that's going on. If you need to reboot while the test is running, go ahead: the test will pick up right where it left off when your computer comes back up.
  5. Your RAM might be bad. Reboot and hold down Left Shift or Esc while it's booting to bring up the GRUB menu. Select Memory test (memtest86+). Make sure your computer is plugged in and its air vents aren't blocked, because this test can use a lot of energy and heat the computer up quite a bit. Let it run overnight while you sleep. See if the error count is over zero when you wake up.

protected by Community Sep 27 '18 at 13:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.